CVE-2005-3047
CVSS4.3
发布时间 :2005-09-23 20:03:00
修订时间 :2016-10-17 23:32:30
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in PhpMyFaq 1.5.1 allow remote attackers to inject arbitrary web script or HTML via the (1) PMF_CONF[version] parameter to footer.php or (2) PMF_LANG[metaLanguage] to header.php.


[CNNVD]PhpMyFaq 多个跨站脚本攻击(XSS)漏洞(CNNVD-200509-239)

        phpMyFAQ是一个多语言,完全数据库驱动的FAQ系统。它支持多种数据库来存储所有数据。
        PhpMyFaq 1.5.1版本中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以借助:(1) footer.php 中的PMF_CONF[version]参数或(2)header.php中的PMF_LANG[metaLanguage]参数执行任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3047
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3047
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-239
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112749230124091&w=2
(UNKNOWN)  BUGTRAQ  20050922 PhpMyFAQ 1.5.1 multiple vulnerabilities
http://rgod.altervista.org/phpmyfuck151.html
(VENDOR_ADVISORY)  MISC  http://rgod.altervista.org/phpmyfuck151.html

- 漏洞信息

PhpMyFaq 多个跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2005-09-23 00:00:00 2009-04-03 00:00:00
远程  
        phpMyFAQ是一个多语言,完全数据库驱动的FAQ系统。它支持多种数据库来存储所有数据。
        PhpMyFaq 1.5.1版本中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以借助:(1) footer.php 中的PMF_CONF[version]参数或(2)header.php中的PMF_LANG[metaLanguage]参数执行任意web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

19667
phpMyFAQ footer.php PMF_CONF[version] Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

phpMyFAQ contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'PMF_CONF[version]' variable upon submission to the footer.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-09-22 Unknow
2005-09-22 Unknow

- 解决方案

Upgrade to version 1.5.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站