CVE-2005-2997
CVSS5.0
发布时间 :2005-09-20 18:03:00
修订时间 :2008-09-05 16:53:11
NMCO    

[原文]Multiple directory traversal vulnerabilities in PHP Advanced Transfer Manager 1.30 allow remote attackers to read arbitrary files via ".." sequences in (1) the currentdir parameter to txt.php, or the current_dir parameter to (2) htm.php or (3) html.php.


[CNNVD]PHP Advanced Transfer Manager多个目录遍历漏洞(CNNVD-200509-177)

        PHP Advanced Transfer Manager是一款文件传送管理程序。
        PHP Advanced Transfer Manager 1.30版本存在多个目录遍历漏洞,导致远程攻击者通过".."(参数中包含'..')读取任意文件。(1)txt.php文件的currentdir参数 (2)htm.php文件或 (3) html.php的current_dir 参数中的序列。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2997
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2997
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-177
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/16867
(UNKNOWN)  SECUNIA  16867
http://rgod.altervista.org/phpatm130.html
(UNKNOWN)  MISC  http://rgod.altervista.org/phpatm130.html

- 漏洞信息

PHP Advanced Transfer Manager多个目录遍历漏洞
中危 路径遍历
2005-09-20 00:00:00 2005-10-20 00:00:00
远程  
        PHP Advanced Transfer Manager是一款文件传送管理程序。
        PHP Advanced Transfer Manager 1.30版本存在多个目录遍历漏洞,导致远程攻击者通过".."(参数中包含'..')读取任意文件。(1)txt.php文件的currentdir参数 (2)htm.php文件或 (3) html.php的current_dir 参数中的序列。

- 公告与补丁

        

- 漏洞信息

19523
PHP Advanced Transfer Manager (phpATM) txt.php currentdir Parameter Traversal Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality
Exploit Public

- 漏洞描述

PHP Advanced Transfer Manager contains a flaw that allows a remote attacker to access arbitrary files outside of the web path. The issue is due to the txt.php script not properly sanitizing user input, specifically traversal style attacks (../../) supplied via the 'current_dir' variable.

- 时间线

2005-09-20 Unknow
2005-09-20 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站