CVE-2005-2950
CVSS4.3
发布时间 :2005-09-16 18:03:00
修订时间 :2016-10-17 23:31:43
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Sawmill 7.0.0 through 7.1.13 allows remote attackers to inject arbitrary web script or HTML via the query string in an HTTP GET request.


[CNNVD]Sawmill跨站点脚本(XSS)漏洞(CNNVD-200509-150)

        Sawmill 是透过分析Log File的方式来提供网站的访客流量数据的软件,让你知道网友的停留时间、浏览网页等的喜好分析。
        Sawmill 7.0.0-7.1.13中的跨站点脚本(XSS)漏洞,允许远程攻击者通过HTTP GET请求中的查询字符串来注入任意的Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:sawmill:sawmill:7.1.13
cpe:/a:sawmill:sawmill:7.1.14
cpe:/a:sawmill:sawmill:7.1.11
cpe:/a:sawmill:sawmill:7.1.12
cpe:/a:sawmill:sawmill:7.1.9
cpe:/a:sawmill:sawmill:7.0.9
cpe:/a:sawmill:sawmill:7.1.8
cpe:/a:sawmill:sawmill:7.0.10d
cpe:/a:sawmill:sawmill:7.0.8
cpe:/a:sawmill:sawmill:7.1.7
cpe:/a:sawmill:sawmill:7.0.10e
cpe:/a:sawmill:sawmill:7.0.7
cpe:/a:sawmill:sawmill:7.1.6
cpe:/a:sawmill:sawmill:7.0.10f
cpe:/a:sawmill:sawmill:7.0.6
cpe:/a:sawmill:sawmill:7.1.5
cpe:/a:sawmill:sawmill:7.0.10g
cpe:/a:sawmill:sawmill:7.0.5
cpe:/a:sawmill:sawmill:7.1.4
cpe:/a:sawmill:sawmill:7.1
cpe:/a:sawmill:sawmill:7.0.10
cpe:/a:sawmill:sawmill:7.0.10h
cpe:/a:sawmill:sawmill:7.0.10i
cpe:/a:sawmill:sawmill:7.0.10j
cpe:/a:sawmill:sawmill:7.0.10k
cpe:/a:sawmill:sawmill:7.0.4
cpe:/a:sawmill:sawmill:7.1.3
cpe:/a:sawmill:sawmill:7.0.10a
cpe:/a:sawmill:sawmill:7.0.3
cpe:/a:sawmill:sawmill:7.1.2
cpe:/a:sawmill:sawmill:7.0.10b
cpe:/a:sawmill:sawmill:7.0.2
cpe:/a:sawmill:sawmill:7.1.1
cpe:/a:sawmill:sawmill:7.0.1
cpe:/a:sawmill:sawmill:7.0.10c
cpe:/a:sawmill:sawmill:7.0.0
cpe:/a:sawmill:sawmill:7.1.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2950
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2950
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-150
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112654659400488&w=2
(UNKNOWN)  BUGTRAQ  20050912 Sawmill XSS vuln
http://securityreason.com/securityalert/1
(UNKNOWN)  SREASON  1
http://www.nta-monitor.com/news/xss/sawmill/index.htm
(VENDOR_ADVISORY)  MISC  http://www.nta-monitor.com/news/xss/sawmill/index.htm
http://www.sawmill.net/version_history.html
(UNKNOWN)  CONFIRM  http://www.sawmill.net/version_history.html
http://xforce.iss.net/xforce/xfdb/22206
(UNKNOWN)  XF  sawmill-unknown-xss(22206)

- 漏洞信息

Sawmill跨站点脚本(XSS)漏洞
中危 跨站脚本
2005-09-16 00:00:00 2005-10-20 00:00:00
远程  
        Sawmill 是透过分析Log File的方式来提供网站的访客流量数据的软件,让你知道网友的停留时间、浏览网页等的喜好分析。
        Sawmill 7.0.0-7.1.13中的跨站点脚本(XSS)漏洞,允许远程攻击者通过HTTP GET请求中的查询字符串来注入任意的Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

19254
Sawmill GET Request Query String XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Sawmill contains a flaw that allows a remote cross site scripting attack. This flaw exists because the server does not validate any query string appended to a GET request. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-09-08 Unknow
2005-09-12 Unknow

- 解决方案

Upgrade to version 7.1.14 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站