CVE-2005-2930
CVSS5.1
发布时间 :2005-10-28 17:02:00
修订时间 :2011-08-02 00:00:00
NMCOPS    

[原文]Stack-based buffer overflow in the _chm_find_in_PMGL function in chm_lib.c for chmlib before 0.36, as used in products such as KchmViewer, allows user-assisted attackers to execute arbitrary code via a CHM file containing a long element, a different vulnerability than CVE-2005-3318.


[CNNVD]Jed Wing CHM Lib _chm_find_in_PMGL栈溢出漏洞(CNNVD-200510-257)

        chmlib是用于处理Microsoft ITSS/CHM格式文件的函数库。
        Chmlib chm_lib.c文件中_chm_find_in_PMGL 函数存在栈溢出漏洞,远程攻击者可能利用此漏洞在主机上执行任意指令。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:jed_wing:chm_lib:0.35
cpe:/a:jed_wing:chm_lib:0.32
cpe:/a:jed_wing:chm_lib:0.33
cpe:/a:jed_wing:chm_lib:0.31
cpe:/a:jed_wing:chm_lib:0.2
cpe:/a:jed_wing:chm_lib:0.3
cpe:/a:jed_wing:chm_lib:0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2930
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2930
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200510-257
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15234
(PATCH)  BID  15234
http://www.idefense.com/application/poi/display?id=332&type=vulnerabilities
(VENDOR_ADVISORY)  IDEFENSE  20051028 Multiple Vendor chmlib CHM File Handling Buffer Overflow Vulnerability
http://securitytracker.com/id?1015120
(VENDOR_ADVISORY)  SECTRACK  1015120
http://secunia.com/advisories/17775
(VENDOR_ADVISORY)  SECUNIA  17775
http://www.vupen.com/english/advisories/2005/2249
(VENDOR_ADVISORY)  VUPEN  ADV-2005-2249
http://securityreason.com/securityalert/125
(UNKNOWN)  SREASON  125

- 漏洞信息

Jed Wing CHM Lib _chm_find_in_PMGL栈溢出漏洞
中危 缓冲区溢出
2005-10-28 00:00:00 2006-08-28 00:00:00
远程  
        chmlib是用于处理Microsoft ITSS/CHM格式文件的函数库。
        Chmlib chm_lib.c文件中_chm_find_in_PMGL 函数存在栈溢出漏洞,远程攻击者可能利用此漏洞在主机上执行任意指令。

- 公告与补丁

        暂无数据

- 漏洞信息 (F41388)

Debian Linux Security Advisory 886-1 (PacketStormID:F41388)
2005-11-08 00:00:00
Debian  security.debian.org
advisory,vulnerability
linux,debian
CVE-2005-2659,CVE-2005-2930,CVE-2005-3318
[点击下载]

Debian Security Advisory DSA 886-1 - Several vulnerabilities have been discovered in chmlib, a library for dealing with CHM format files.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 886-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
November 7th, 2005                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : chmlib
Vulnerability  : several
Problem type   : local (remote)
Debian-specific: no
CVE IDs        : CVE-2005-2659 CVE-2005-2930 CVE-2005-3318
BugTraq ID     : 15211

Several vulnerabilities have been discovered in chmlib, a library for
dealing with CHM format files.  The Common Vulnerabilities and
Exposures project identifies the following problems:

CVE-2005-2659

    Palasik Sandor discoverd a buffer overflow in the LZX
    decompression method.

CVE-2005-2930

    A buffer overflow has been discovered that could lead to the
    execution of arbitrary code.

CVE-2005-3318

    Sven Tantau discoverd a buffer overflow that could lead to the
    execution of arbitrary code.

The old stable distribution (woody) does not contain chmlib packages.

For the stable distribution (sarge) these problems have been fixed in
version 0.35-6sarge1.

For the unstable distribution (sid) these problems have been fixed in
version 0.37-2.

We recommend that you upgrade your chmlib packages.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1.dsc
      Size/MD5 checksum:      604 022d55ea43ef4a54648b0823163c4a07
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1.diff.gz
      Size/MD5 checksum:    15698 55eeab9a32a66c5e123ab51f3d7427df
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35.orig.tar.gz
      Size/MD5 checksum:   368428 8fa0e692b2606a03fb51589f66a82eec

  Alpha architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_alpha.deb
      Size/MD5 checksum:    25688 2471920dc5214b95a44e50e2a8800ada
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_alpha.deb
      Size/MD5 checksum:    18576 0b1d802a79cea68c00d36cd9cb7a36cd
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_alpha.deb
      Size/MD5 checksum:    25544 23306cc3f7b0772f744707c86fa9258a

  AMD64 architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_amd64.deb
      Size/MD5 checksum:    23748 e5a72c3311e7b00d6295a75f7bb37560
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_amd64.deb
      Size/MD5 checksum:    16928 8a2d68579e364a284c03dcc4b9a01e37
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_amd64.deb
      Size/MD5 checksum:    22564 50d2a8d694d1bf7251d18b4f7b02ede7

  ARM architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_arm.deb
      Size/MD5 checksum:    25242 ec14b38be010c3f1fee93dd618124c5e
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_arm.deb
      Size/MD5 checksum:    15962 5e1ec37635078cc29b9f2a4f91f9b20e
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_arm.deb
      Size/MD5 checksum:    24000 bc84ed2d77918f6eb4378f35f43cd4e5

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_i386.deb
      Size/MD5 checksum:    24872 fbea0ba2924295a9f553c346eeb164af
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_i386.deb
      Size/MD5 checksum:    16094 de94d72e5414d1b218fd32f11cd7351b
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_i386.deb
      Size/MD5 checksum:    22872 3e37bda96c284423f467aecb88e8dc98

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_ia64.deb
      Size/MD5 checksum:    28504 ef19dde34158fa817781c685d2499cbb
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_ia64.deb
      Size/MD5 checksum:    19348 e15dc8288ba0a0bee7a9490c4fe653de
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_ia64.deb
      Size/MD5 checksum:    27268 497388fcd7e08a7558dde96082b2707a

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_hppa.deb
      Size/MD5 checksum:    27748 1be03e42641d4a3a409bf5604e1b15a8
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_hppa.deb
      Size/MD5 checksum:    18060 290679f0522440bd4ab925fb3f883b60
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_hppa.deb
      Size/MD5 checksum:    24192 7e4c8b5b62bb7ab2eb14f01e54b64453

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_m68k.deb
      Size/MD5 checksum:    23124 e845c33b36a51d713fd4cf5ba24aa136
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_m68k.deb
      Size/MD5 checksum:    16256 25a7901e4b91497528bdf582b43b5df3
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_m68k.deb
      Size/MD5 checksum:    21626 aa4166c4ee0660cbf5ecefff086e871b

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_mips.deb
      Size/MD5 checksum:    26552 456bd641bda1da859c9769c5dbac0212
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_mips.deb
      Size/MD5 checksum:    23108 5f289432c7bcfb2bf5945b688aa3e80a
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_mips.deb
      Size/MD5 checksum:    25098 589bb8b01be1943c4813afb477b1a83c

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_mipsel.deb
      Size/MD5 checksum:    26582 36348c9aa4b47d9426481a2faf90e98a
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_mipsel.deb
      Size/MD5 checksum:    23128 c970a6faf21ba157d72c1dd8720fe307
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_mipsel.deb
      Size/MD5 checksum:    25082 4bb261ab9c4b19623a0e53e0063f920f

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_powerpc.deb
      Size/MD5 checksum:    27380 7e7d08b907286bf4b326a97ed0b9ad72
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_powerpc.deb
      Size/MD5 checksum:    22032 a24a33a3eba0b35608f23159fab58a4d
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_powerpc.deb
      Size/MD5 checksum:    23558 6a0564ea6c10034569bf0b428c372dd9

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_s390.deb
      Size/MD5 checksum:    26606 d2b7c824f1118f3088daacd66c9e6e61
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_s390.deb
      Size/MD5 checksum:    17486 42591c148ddfb9df1a3c1d9006e609e5
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_s390.deb
      Size/MD5 checksum:    23454 e4a6426fe3831ebb9e2afc47565fa191

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/c/chmlib/chmlib_0.35-6sarge1_sparc.deb
      Size/MD5 checksum:    24332 b41c04b1d6df50931ddfe8eafa61d19f
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-bin_0.35-6sarge1_sparc.deb
      Size/MD5 checksum:    16110 17aba1dae25700043a23aa9863a190f0
    http://security.debian.org/pool/updates/main/c/chmlib/chmlib-dev_0.35-6sarge1_sparc.deb
      Size/MD5 checksum:    22330 5e0e711c063af5b5c982224d1eeef5e5


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDb3hAW5ql+IAeqTIRAka0AJ9RPzISyqYgvN8jN2IZJYblPIOKiQCcC91Y
ddzMmEtmr75gyUfioFiKUek=
=Wy08
-----END PGP SIGNATURE-----

    

- 漏洞信息 (F41075)

iDEFENSE Security Advisory 2005-10-28.t (PacketStormID:F41075)
2005-10-30 00:00:00
iDefense Labs  idefense.com
advisory,remote,overflow,arbitrary
linux
CVE-2005-2930
[点击下载]

iDEFENSE Security Advisory 10.28.05 - Remote exploitation of a stack overflow vulnerability in chmlib as included in various Linux distributions allows attackers to execute arbitrary code. The vulnerability specifically exists due to an unchecked memory copy while processing a CHM file. iDefense has confirmed the existence of this vulnerability in chmlib 0.35. It is suspected that all versions of chmlib are vulnerable.

Multiple Vendor chmlib CHM File Handling Buffer Overflow Vulnerability
 
iDefense Security Advisory 10.28.05
www.idefense.com/application/poi/display?id=332&type=vulnerabilities
October 28, 2005
 
I. BACKGROUND
 
chmlib is a library for dealing with Microsoft ITSS/CHM format files.
 
II. DESCRIPTION
 
Remote exploitation of a stack overflow vulnerability in chmlib as 
included in various Linux distributions allows attackers to execute 
arbitrary code.
 
The vulnerability specifically exists due to an unchecked memory copy 
while processing a CHM file. The vulnerability exists in the following 
code, which is found in chm_lib.c: 
 
static UChar *_chm_find_in_PMGL(UChar *page_buf,
                                UInt32 
block_len,
                                const 
char *objPath)
{
[...]
  char buffer[CHM_MAX_PATHLEN+1];    
    /* figure out where to start and end */
    cur = page_buf;
    hremain = _CHM_PMGL_LEN;
    if (! _unmarshal_pmgl_header(&cur, &hremain, &header))
        return NULL;
    end = page_buf + block_len - (header.free_space);
    
    /* now, scan progressively */
    while (cur < end)
    {
        /* grab the name */
        temp = cur;
        strLen = _chm_parse_cword(&cur);
        if (! _chm_parse_UTF8(&cur, strLen, buffer))
            return NULL;
[..] 
 
_chm_parse_cword can be forced to return a value larger than 
CHM_MAX_PATHLEN. This value is then used while copying user controlled 
data into a CHM_MAX_PATHLEN sized stack buffer. This allows the attacker

full control over execution flow by overwriting the saved return address

on the stack.
 
III. ANALYSIS
 
Exploitation could allow attackers to execute arbitrary code with the 
privileges of the user processing the CHM file. Remote exploitation can 
be achieved by sending a malicious file in an e-mail message to the 
target user.
 
IV. DETECTION
 
iDefense has confirmed the existence of this vulnerability in chmlib 
0.35. It is suspected that all versions of chmlib are vulnerable. 
 
The following vendors distribute susceptible chmlib packages within 
their respective operating system distributions:
 
 FreeBSD Project:
   FreeBSD 5.4 and prior
 Gentoo Foundation Inc.:
   Gentoo Linux 1.1a, 1.2, 1.4, 2004.0, 2004.1 and 2004.2 
 
V. WORKAROUND
 
Do not open CHM files sent from an untrusted source.
 
VI. VENDOR RESPONSE
 
chmlib-0.36 addresses this vulnerability and is available for download
at:
 
   http://freshmeat.net/projects/chmlib/
 
VII. CVE INFORMATION
 
The Common Vulnerabilities and Exposures (CVE) project has assigned the
name CAN-2005-2930 to this issue. This is a candidate for inclusion in
the CVE list (http://cve.mitre.org), which standardizes names for
security problems.
 
VIII. DISCLOSURE TIMELINE
 
09/08/2005  Initial vendor notification
09/09/2005  Initial vendor response
10/28/2005  Public disclosure
 
IX. CREDIT
 
The discoverer of this vulnerability wishes to remain anonymous.
 
Get paid for vulnerability research
http://www.iDefense.com/poi/teams/vcp.jsp
 
Free tools, research and upcoming events
http://labs.iDefense.com
 
X. LEGAL NOTICES
 
Copyright (c) 2005 iDefense, Inc.
 
Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDefense. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@iDefense.com for permission.
 
Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.

    

- 漏洞信息

20512
chmlib chm_lib.c _chm_find_in_PMGL element Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2005-10-28 Unknow
Unknow 2005-09-12

- 解决方案

Upgrade to version 0.36 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Jed Wing CHM Lib _chm_find_in_PMGL Stack Buffer Overflow Vulnerability
Boundary Condition Error 15234
Yes No
2005-10-28 12:00:00 2009-07-12 05:56:00
The discoverer of this issue wishes to remain anonymous.

- 受影响的程序版本

Jed Wing CHM lib 0.36
Jed Wing CHM lib 0.35
Jed Wing CHM lib 0.33
Jed Wing CHM lib 0.32
Jed Wing CHM lib 0.31
Jed Wing CHM lib 0.3
Jed Wing CHM lib 0.2
Jed Wing CHM lib 0.1
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Jed Wing CHM lib 0.37
Jed Wing CHM lib 0.36

- 不受影响的程序版本

Jed Wing CHM lib 0.37
Jed Wing CHM lib 0.36

- 漏洞讨论

CHM lib is susceptible to a buffer overflow vulnerability. This issue is due to a failure of the library to properly bounds check input data prior to copying it into an insufficiently sized memory buffer.

This issue allows attackers to execute arbitrary machine code in the context of the application that utilizes the CHM lib library.

This issue is present in versions 0.35; other versions may also be affected.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

The vendor has released version 0.36 of CHM lib to address this issue.

Debian has released advisory DSA 886-1 to address this issue. Please see the referenced advisory for more information.


Jed Wing CHM lib 0.1

Jed Wing CHM lib 0.2

Jed Wing CHM lib 0.3

Jed Wing CHM lib 0.31

Jed Wing CHM lib 0.32

Jed Wing CHM lib 0.33

Jed Wing CHM lib 0.35

Jed Wing CHM lib 0.36

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站