发布时间 :2005-10-25 12:02:00
修订时间 :2008-09-10 15:44:13

[原文]Stack-based buffer overflow in ppp in SCO Unixware 7.1.3 and 7.1.4, and possibly earlier versions, allows local users to execute arbitrary code via a long argument to the (1) prompt or (2) defprompt command.

[CNNVD]SCO UnixWare PPP提示本地溢出漏洞(CNNVD-200510-204)

        SCO Unixware的ppp提示中存在缓冲区溢出漏洞。如果运行ppp程序的用户对"prompt"或"defprompt"命令输入了超过256个字节的参数的话,就可能导致栈溢出,允许本地攻击者获得root权限,因为ppp默认为setuid root。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  15159
(UNKNOWN)  IDEFENSE  20051024 SCO Unixware Setuid ppp prompt Buffer Overflow Vulnerability

- 漏洞信息

SCO UnixWare PPP提示本地溢出漏洞
高危 缓冲区溢出
2005-10-25 00:00:00 2005-10-25 00:00:00
        SCO Unixware的ppp提示中存在缓冲区溢出漏洞。如果运行ppp程序的用户对"prompt"或"defprompt"命令输入了超过256个字节的参数的话,就可能导致栈溢出,允许本地攻击者获得root权限,因为ppp默认为setuid root。

- 公告与补丁


- 漏洞信息

SCO UnixWare ppp Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

A local overflow exists in UnixWare. The 'ppptalk' binary fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request, a malicious user can cause arbitrary code execution with root privileges resulting in a loss of integrity.

- 时间线

2005-10-20 Unknow
Unknow 2005-10-20

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, SCO has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SCO UnixWare PPP Prompt Local Buffer Overflow Vulnerability
Boundary Condition Error 15159
No Yes
2005-10-20 12:00:00 2009-07-12 05:56:00
Discovery is credited to iDEFENSE Labs.

- 受影响的程序版本

SCO Unixware 7.1.4
SCO Unixware 7.1.3

- 漏洞讨论

SCO UnixWare is prone to a local buffer-overflow vulnerability.

The vulnerability presents itself when the application processes excessive data supplied through the Unixware point-to-point protocol (PPP) prompt.

UnixWare 7.1.4 and 7.1.3 are reported prone to this issue.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 解决方案

SCO has released advisory SCOSA-2005.41 to address this issue. Please see the referenced advisory for more information about obtaining and applying fixes.

SCO Unixware 7.1.3

SCO Unixware 7.1.4

- 相关参考