发布时间 :2005-09-14 17:03:00
修订时间 :2008-09-05 16:52:58

[原文]ezconfig.asp in Linksys WRT54G router 3.01.03, 3.03.6, non-default configurations of 2.04.4, and possibly other versions, does not use an authentication initialization function, which allows remote attackers to obtain encrypted configuration information and, if the key is known, modify the configuration.

[CNNVD]Linksys WRT54G配置信息泄漏漏洞(CNNVD-200509-134)

        Linksys WRT54G是Cisco公司的一款无线路由器。
        Linksys WRT54G路由器3.01.03, 3.03.6中的ezconfig.asp是2.04.4以及可能其他版本的非默认配置,不使用身份验证初始化函数,从而远程攻击者可以获取加密的配置信息,并且如果知道密钥,则可以修改配置。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/h:linksys:wrt54g:3.03.6Linksys WRT54G 3.03.6
cpe:/h:linksys:wrt54g:2.04.4Linksys WRT54G 2.04.4
cpe:/h:linksys:wrt54g:3.01.3Linksys WRT54G 3.01.3

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  IDEFENSE  20050913 Linksys WRT54G Router Remote Administration Fixed Encryption Key Vulnerability

- 漏洞信息

Linksys WRT54G配置信息泄漏漏洞
高危 未知
2005-09-14 00:00:00 2005-10-20 00:00:00
        Linksys WRT54G是Cisco公司的一款无线路由器。
        Linksys WRT54G路由器3.01.03, 3.03.6中的ezconfig.asp是2.04.4以及可能其他版本的非默认配置,不使用身份验证初始化函数,从而远程攻击者可以获取加密的配置信息,并且如果知道密钥,则可以修改配置。

- 公告与补丁


- 漏洞信息

Cisco Linksys WRT54G ezconfig.asp Encryption Weakness Authentication Issue
Remote / Network Access Cryptographic
Loss of Integrity

- 漏洞描述

Linksys Wireless-G Router WRT54G contains a flaw that may allow a remote attacker to manipulate arbitrary router settings. The problem is that the 'auth()' method in 'ezconfig.asp' does not contain an authentication initialization function, which may allow a remote attacker to obtain encrypted configuration information and manipulate arbitrary router settings resulting in a loss of integrity.

- 时间线

2005-09-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to firmware 4.20.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者