CVE-2005-2860
CVSS4.3
发布时间 :2005-09-08 06:03:00
修订时间 :2016-10-17 23:30:54
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Nikto 1.35 and earlier allows remote attackers to inject arbitrary web script or HTML via the Server field in an HTTP response header, which is directly injected into an HTML report.


[CNNVD]Nikto跨站脚本漏洞(CNNVD-200509-074)

        Nikto是一款开源的(GPL)网页服务器扫描器,它可以对网页服务器进行全面的多种扫描,包含超过3300种有潜在危险的文件/CGIs;超过625 种服务器版本;超过230种特定服务器问题。扫描项和插件可以自动更新(如果需要)。基于Whisker/libwhisker完成其底层功能。
        Nikto 1.35 及以前版本中的跨站脚本(XSS)漏洞允许远程攻击者通过 HTTP 响应头中的服务器字段将任意 web 脚本或 HTML直接注入到 HTML 报告。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2860
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2860
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-074
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112561344400914&w=2
(UNKNOWN)  BUGTRAQ  20050901 CYBSEC - Multiple Vendor Web Vulnerability Scanner Arbitrary Script
http://seclists.org/lists/vulnwatch/2005/Jul-Sep/0032.html
(VENDOR_ADVISORY)  VULNWATCH  20050901 CYBSEC - Multiple Vendor Web Vulnerability Scanner Arbitrary Script Injection Vulnerability
http://www.cybsec.com/vuln/010905-multiple_webscanner_script_injection.pdf
(VENDOR_ADVISORY)  MISC  http://www.cybsec.com/vuln/010905-multiple_webscanner_script_injection.pdf
http://www.securityfocus.com/bid/14717
(UNKNOWN)  BID  14717

- 漏洞信息

Nikto跨站脚本漏洞
中危 跨站脚本
2005-09-08 00:00:00 2005-10-20 00:00:00
远程  
        Nikto是一款开源的(GPL)网页服务器扫描器,它可以对网页服务器进行全面的多种扫描,包含超过3300种有潜在危险的文件/CGIs;超过625 种服务器版本;超过230种特定服务器问题。扫描项和插件可以自动更新(如果需要)。基于Whisker/libwhisker完成其底层功能。
        Nikto 1.35 及以前版本中的跨站脚本(XSS)漏洞允许远程攻击者通过 HTTP 响应头中的服务器字段将任意 web 脚本或 HTML直接注入到 HTML 报告。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.nstalker.com/eng/products/nstealth/free/download.php

- 漏洞信息

17886
Nikto HTML Report Server Header Arbitrary Script Injection
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Nikto contains a flaw that may allow a remote attacker to inject arbitrary script code. The issue occurs when a user runs Nikto with the -F option, specifying HTML output. With a cleverly crafted server header string, an attacker can inject custom script into the HTML generated report. When the user views the report in a graphical web browser, the script may be executed under the privileges of that user.

- 时间线

2005-07-27 2005-07-26
2005-07-27 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround: do not output the report in HTML format.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站