CVE-2005-2853
CVSS4.3
发布时间 :2005-09-08 06:03:00
修订时间 :2008-09-05 16:52:50
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in GuppY 4.5.3a and earlier allow remote attackers to inject arbitrary web script or HTML via (1) the pg parameter to printfaq.php, or the (2) Referer or (3) User-Agent HTTP headers, which are not properly handled by error.php.


[CNNVD]GuppY多个跨站脚本漏洞(CNNVD-200509-077)

        一款来自法国的CMS系统,带有论坛、新闻、留言、下载等众多模块。
        GuppY 4.5.3a及以前版本中多个跨站脚本(XXS)漏洞允许远程攻击者通过以下方式注入任意web 脚本:(1)通过pg参数向printfaq.php向注入;(2)通过Referer属性;(3)通过用户代理HTTP请求头,因为error.php没有正确操作。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:guppy:guppy:4.5.3a
cpe:/a:guppy:guppy:4.5
cpe:/a:guppy:guppy:4.5.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2853
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2853
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-077
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14753
(PATCH)  BID  14753
http://www.freeguppy.org/download.php?lng=en
(PATCH)  CONFIRM  http://www.freeguppy.org/download.php?lng=en
http://secunia.com/advisories/16707
(VENDOR_ADVISORY)  SECUNIA  16707
http://www.freeguppy.org/thread.php?lng=en&pg=81882&fid=1&cat=200
(UNKNOWN)  CONFIRM  http://www.freeguppy.org/thread.php?lng=en&pg=81882&fid=1&cat=200

- 漏洞信息

GuppY多个跨站脚本漏洞
中危 跨站脚本
2005-09-08 00:00:00 2005-10-20 00:00:00
远程  
        一款来自法国的CMS系统,带有论坛、新闻、留言、下载等众多模块。
        GuppY 4.5.3a及以前版本中多个跨站脚本(XXS)漏洞允许远程攻击者通过以下方式注入任意web 脚本:(1)通过pg参数向printfaq.php向注入;(2)通过Referer属性;(3)通过用户代理HTTP请求头,因为error.php没有正确操作。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        GuppY 4.5 版
        GuppY gy_upg_454.zip
        http://www.freeguppy.org/file/gy_upg_454.zip
        GuppY GuppY 4.5.3 a
        GuppY gy_upg_454.zip
        http://www.freeguppy.org/file/gy_upg_454.zip
        GuppY GuppY 4.5.3
        GuppY gy_upg_454.zip
        http://www.freeguppy.org/file/gy_upg_454.zip

- 漏洞信息

19243
GuppY Multiple HTTP Header XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

- 时间线

2005-09-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.5.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站