CVE-2005-2836
CVSS4.3
发布时间 :2005-09-07 16:03:00
修订时间 :2008-09-05 16:52:47
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Phorum 5.0.17a and earlier allow remote attackers to inject arbitrary web script or HTML via (1) the username parameter to register.php or (2) a signature of a logged-in user in "My Control Center," which is not properly handled by control.php.


[CNNVD]Phorum多个跨站脚本漏洞(CNNVD-200509-062)

        Phorum是一个基于PHP+MySQL开发的开源论坛项目。它的特点是速度快,功能强大,面向模块化设计,安装简单。此外Phorum还集成电子报。
        Phorum 5.0.17a 及以前版本中的多个跨站脚本(XSS)漏洞允许远程攻击者通过以下方式注入任意 web 脚本: (1)通过用户名参数向 register.php 文件注入; (2)通过"我的控制中心"中登录用户签字,这是由于 control.php 没有正确操作。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phorum:phorum:3.4Phorum 3.4
cpe:/a:phorum:phorum:5.0.3_beta
cpe:/a:phorum:phorum:3.1Phorum 3.1
cpe:/a:phorum:phorum:5.0.15Phorum 5.0.15
cpe:/a:phorum:phorum:5.0.7_beta
cpe:/a:phorum:phorum:5.0.16Phorum 5.0.16
cpe:/a:phorum:phorum:3.1.1a
cpe:/a:phorum:phorum:3.3.1a
cpe:/a:phorum:phorum:5.0.9Phorum 5.0.9
cpe:/a:phorum:phorum:3.2.3a
cpe:/a:phorum:phorum:3.2.5Phorum 3.2.5
cpe:/a:phorum:phorum:3.2.7Phorum 3.2.7
cpe:/a:phorum:phorum:3.3.2a
cpe:/a:phorum:phorum:3.1.2Phorum 3.1.2
cpe:/a:phorum:phorum:3.2.2Phorum 3.2.2
cpe:/a:phorum:phorum:3.1.1Phorum 3.1.1
cpe:/a:phorum:phorum:3.4.3Phorum 3.4.3
cpe:/a:phorum:phorum:5.0.12Phorum 5.0.12
cpe:/a:phorum:phorum:3.4.5Phorum 3.4.5
cpe:/a:phorum:phorum:3.2.3b
cpe:/a:phorum:phorum:3.2.8Phorum 3.2.8
cpe:/a:phorum:phorum:3.4.7Phorum 3.4.7
cpe:/a:phorum:phorum:3.2.3Phorum 3.2.3
cpe:/a:phorum:phorum:3.4.2Phorum 3.4.2
cpe:/a:phorum:phorum:3.3.1Phorum 3.3.1
cpe:/a:phorum:phorum:3.3.2Phorum 3.3.2
cpe:/a:phorum:phorum:3.1.1_pre
cpe:/a:phorum:phorum:5.0.17Phorum 5.0.17
cpe:/a:phorum:phorum:4.3.7Phorum 4.3.7
cpe:/a:phorum:phorum:3.3.2b3
cpe:/a:phorum:phorum:3.2Phorum 3.2
cpe:/a:phorum:phorum:3.2.4Phorum 3.2.4
cpe:/a:phorum:phorum:3.2.6Phorum 3.2.6
cpe:/a:phorum:phorum:5.0.11Phorum 5.0.11
cpe:/a:phorum:phorum:3.1.1_rc2
cpe:/a:phorum:phorum:5.0.14Phorum 5.0.14
cpe:/a:phorum:phorum:3.4.8Phorum 3.4.8
cpe:/a:phorum:phorum:3.4.1Phorum 3.4.1
cpe:/a:phorum:phorum:3.4.4Phorum 3.4.4
cpe:/a:phorum:phorum:5.0.10Phorum 5.0.10
cpe:/a:phorum:phorum:5.0.14a
cpe:/a:phorum:phorum:3.4.6Phorum 3.4.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2836
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2836
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-062
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/16667
(VENDOR_ADVISORY)  SECUNIA  16667
http://archives.neohapsis.com/archives/fulldisclosure/2005-09/0018.html
(VENDOR_ADVISORY)  FULLDISC  20050901 Multiple Phorum XSS and Session Hijacking vulnerabilities
http://archives.neohapsis.com/archives/fulldisclosure/2005-09/0048.html
(VENDOR_ADVISORY)  FULLDISC  20050902 Re: Multiple Phorum XSS and Session Hijacking vulnerabilities

- 漏洞信息

Phorum多个跨站脚本漏洞
中危 跨站脚本
2005-09-07 00:00:00 2005-10-20 00:00:00
远程  
        Phorum是一个基于PHP+MySQL开发的开源论坛项目。它的特点是速度快,功能强大,面向模块化设计,安装简单。此外Phorum还集成电子报。
        Phorum 5.0.17a 及以前版本中的多个跨站脚本(XSS)漏洞允许远程攻击者通过以下方式注入任意 web 脚本: (1)通过用户名参数向 register.php 文件注入; (2)通过"我的控制中心"中登录用户签字,这是由于 control.php 没有正确操作。

- 公告与补丁

        

- 漏洞信息

19155
Phorum register.php Username Field XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Phorum contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user-supplied input in the 'Username' field upon submission to the 'register.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-09-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 5.0.18a or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站