CVE-2005-2803
CVSS4.3
发布时间 :2005-09-06 17:03:00
修订时间 :2008-11-11 00:53:03
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Hiki 0.8.1 to 0.8.2 allows remote attackers to inject arbitrary web script or HTML via a page name in a Login link, a different vulnerability than CVE-2005-2336.


[CNNVD]Hiki 跨站脚本(XSS)漏洞(CNNVD-200509-034)

        Hiki是用Ruby编写的免费wiki百科全书工具。
        Hiki 0.8.1至0.8.2版本存在多个跨站脚本漏洞。这使得远程攻击者可借助于登陆链接中的页名注入web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:hiki:hiki:0.8.2
cpe:/a:hiki:hiki:0.8.1
cpe:/a:hiki:hiki:0.8.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2803
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2803
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-034
(官方数据源) CNNVD

- 其它链接及资源

http://hikiwiki.org/en/advisory20050804.html
(VENDOR_ADVISORY)  CONFIRM  http://hikiwiki.org/en/advisory20050804.html
http://jvn.jp/jp/JVN%2338138980
(UNKNOWN)  JVN  JVN#38138980
http://www.securityfocus.com/bid/15021
(UNKNOWN)  BID  15021
http://secunia.com/advisories/17075
(UNKNOWN)  SECUNIA  17075

- 漏洞信息

Hiki 跨站脚本(XSS)漏洞
中危 跨站脚本
2005-09-06 00:00:00 2005-10-25 00:00:00
远程  
        Hiki是用Ruby编写的免费wiki百科全书工具。
        Hiki 0.8.1至0.8.2版本存在多个跨站脚本漏洞。这使得远程攻击者可借助于登陆链接中的页名注入web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        Hiki Hiki 0.8
        Hiki hiki-0.8.4.tar.gz
        http://prdownloads.sourceforge.jp/hiki/16704/hiki-0.8.4.tar.gz
        Hiki Hiki 0.8.1
        Hiki hiki-0.8.4.tar.gz
        http://prdownloads.sourceforge.jp/hiki/16704/hiki-0.8.4.tar.gz
        Hiki Hiki 0.8.2
        Hiki hiki-0.8.4.tar.gz
        http://prdownloads.sourceforge.jp/hiki/16704/hiki-0.8.4.tar.gz

- 漏洞信息

19344
Hiki Login Link XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Hiki contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate a page name in a 'Login' link. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-08-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.8.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站