CVE-2005-2797
CVSS5.0
发布时间 :2005-09-06 13:03:00
修订时间 :2016-12-07 22:00:07
NMCOS    

[原文]OpenSSH 4.0, and other versions before 4.2, does not properly handle dynamic port forwarding ("-D" option) when a listen address is not provided, which may cause OpenSSH to enable the GatewayPorts functionality.


[CNNVD]OpenSSH DynamicForward 非故意的的GatewayPorts激活漏洞(CNNVD-200509-044)

        OpenSSH 是 SSH (Secure SHell) 协议的免费开源实现。它用安全、加密的网络连接工具代替了 telnet、ftp、 rlogin、rsh 和 rcp 工具。
        当不提供监听地址时,OpenSSH 4.0及4.2以前的其它版本均不能正确地处理动态端口转发("-D"选项)。这可能导致OpenSSH启动GatewayPorts功能。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2797
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2797
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-044
(官方数据源) CNNVD

- 其它链接及资源

ftp://ftp.sco.com/pub/updates/OpenServer/SCOSA-2006.11/SCOSA-2006.11.txt
(UNKNOWN)  SCO  SCOSA-2006.11
ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2005.53/SCOSA-2005.53.txt
(UNKNOWN)  SCO  SCOSA-2005.53
http://marc.info/?l=bugtraq&m=112605977304049&w=2
(UNKNOWN)  OPENPKG  OpenPKG-SA-2005.019
http://secunia.com/advisories/18661
(UNKNOWN)  SECUNIA  18661
http://securitytracker.com/id?1014845
(UNKNOWN)  SECTRACK  1014845
http://support.avaya.com/elmodocs2/security/ASA-2006-033.htm
(UNKNOWN)  SECUNIA  18661
http://www.mindrot.org/pipermail/openssh-unix-announce/2005-September/000083.html
(VENDOR_ADVISORY)  MLIST  [openssh-unix-announce] 20050901 Announce: OpenSSH 4.2 released
http://www.securityfocus.com/bid/14727
(UNKNOWN)  BID  14727

- 漏洞信息

OpenSSH DynamicForward 非故意的的GatewayPorts激活漏洞
中危 设计错误
2005-09-06 00:00:00 2006-03-28 00:00:00
远程  
        OpenSSH 是 SSH (Secure SHell) 协议的免费开源实现。它用安全、加密的网络连接工具代替了 telnet、ftp、 rlogin、rsh 和 rcp 工具。
        当不提供监听地址时,OpenSSH 4.0及4.2以前的其它版本均不能正确地处理动态端口转发("-D"选项)。这可能导致OpenSSH启动GatewayPorts功能。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        Slackware Linux -current
        Slackware openssh-4.2p1-i486-1.tgz
        ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/n/openssh-4.2p1-i486-1.tgz
        OpenSSH OpenSSH 4.0 p1
        OpenSSH openssh-4.2.tar.gz
        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/openssh-4.2.tar.gz
        RedHat Fedora openssh-4.2p1-fc4.1.i386.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-4.2p1-fc4.1.ppc.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-4.2p1-fc4.1.x86_64.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-askpass-4.2p1-fc4.1.i386.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-askpass-4.2p1-fc4.1.ppc.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-askpass-4.2p1-fc4.1.x86_64.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-askpass-gnome-4.2p1-fc4.1.i386.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-askpass-gnome-4.2p1-fc4.1.ppc.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-askpass-gnome-4.2p1-fc4.1.x86_64.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-clients-4.2p1-fc4.1.i386.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-clients-4.2p1-fc4.1.ppc.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-clients-4.2p1-fc4.1.x86_64.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-debuginfo-4.2p1-fc4.1.i386.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-debuginfo-4.2p1-fc4.1.ppc.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-debuginfo-4.2p1-fc4.1.x86_64.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-server-4.2p1-fc4.1.i386.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-server-4.2p1-fc4.1.ppc.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora openssh-server-4.2p1-fc4.1.x86_64.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        OpenSSH OpenSSH 4.0
        OpenSSH openssh-4.2.tar.gz
        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/openssh-4.2.tar.gz
        OpenSSH OpenSSH 4.1
        OpenSSH openssh-4.2.tar.gz
        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/openssh-4.2.tar.gz
        SCO Open Server 5.0.6 a
        SCO openssh42p1_vol.tar
        ftp://ftp.sco.com/pub/openserver5/opensrc/openssh-4.2p1/openssh42p1_vol.tar
        SCO Open Server 5.0.6
        SCO openssh42p1_vol.tar
        ftp://ftp.sco.com/pub/openserver5/opensrc/openssh-4.2p1/openssh42p1_vol.tar
        SCO Open Server 5.0.7
        SCO osr507mp4_vol.tar for SCOSA-2006.11
        ftp://ftp.sco.com/pub/openserver5/507/mp/osr507mp4/osr507mp4_vol.tar
        SCO Open Server 6.0
        SCO osr600mp2.iso
        OpenServer 6.0.0
        ftp://ftp.sco.com/pub/openserver6/600/mp/osr600mp2/osr600mp2.iso
        SCO Unixware 7.1.3
        SCO SCOSA-2005.53
        UnixWare 7.1.3
        ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2005.53
        SCO Unixware 7.1.4
        SCO SCOSA-2005.53
        UnixWare 7.1.4
        ftp://ftp.sco.com/pub/updates/

- 漏洞信息

19142
OpenSSH Multiple X11 Channel Forwarding Leaks
Local Access Required Misconfiguration
Loss of Integrity

- 漏洞描述

OpenSSH contains a flaw that may allow or enable some X11 forwarding functionality unintentionally. The issue can occur when multiple X11 forwarding requests are made on the same session, single_connection listeners or when an X11 listener is orphaned after a session goes away.

- 时间线

2005-09-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.2p1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

OpenSSH DynamicForward Inadvertent GatewayPorts Activation Vulnerability
Design Error 14727
Yes No
2005-09-01 12:00:00 2006-06-19 04:10:00
The vendor disclosed this issue.

- 受影响的程序版本

Slackware Linux -current
SCO Unixware 7.1.4
SCO Unixware 7.1.3
SCO Open Server 6.0
SCO Open Server 5.0.7
SCO Open Server 5.0.6 a
SCO Open Server 5.0.6
Red Hat Fedora Core4
OpenSSH OpenSSH 4.1
OpenSSH OpenSSH 4.0 p1
OpenSSH OpenSSH 4.0
Avaya Intuity Audix R5 0
OpenSSH OpenSSH 4.2

- 不受影响的程序版本

OpenSSH OpenSSH 4.2

- 漏洞讨论

OpenSSH is susceptible to a vulnerability that causes improper activation of the 'GatewayPorts' option, allowing unintended hosts to use the SSH SOCKS proxy.

Specifically, if the 'DynamicForward' option is activated, 'GatewayPorts' is also unconditionally enabled.

This vulnerability allows remote attackers to use the SOCKS proxy to make arbitrary TCP connections through the configured SSH session, allowing them to attack computers and services through a connection that was wrongly thought to be secure.

This issue affects OpenSSH 4.0, and 4.1.

- 漏洞利用

An exploit is not required.

- 解决方案

Please see the referenced vendor advisories for more information.

The vendor has released version 4.2 of OpenSSH to address this issue.


Slackware Linux -current

OpenSSH OpenSSH 4.0 p1

OpenSSH OpenSSH 4.0

OpenSSH OpenSSH 4.1

SCO Open Server 5.0.6 a

SCO Open Server 5.0.6

SCO Open Server 5.0.7

SCO Open Server 6.0

SCO Unixware 7.1.3

SCO Unixware 7.1.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站