CVE-2005-2763
CVSS7.5
发布时间 :2005-09-06 19:03:00
修订时间 :2011-03-07 21:25:00
NMCOPS    

[原文]Multiple format string vulnerabilities in OpenTTD before 0.4.0.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.


[CNNVD]OpenTTD 多个格式化字符串漏洞(CNNVD-200509-042)

        OpenTTD是一款开放源码的游戏引擎。
        OpenTTD before 0.4.0.1之前的版本中存在多个格式化字符串漏洞。这使得远程攻击者可以造成服务拒绝(崩溃)并可能借助于未明方法执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:openttd:openttd:0.3.6
cpe:/a:openttd:openttd:0.1.4
cpe:/a:openttd:openttd:0.2.0
cpe:/a:openttd:openttd:0.2.1
cpe:/a:openttd:openttd:0.3.4
cpe:/a:openttd:openttd:0.1.3
cpe:/a:openttd:openttd:0.3.3
cpe:/a:openttd:openttd:0.3.1
cpe:/a:openttd:openttd:0.4.0
cpe:/a:openttd:openttd:0.3.5
cpe:/a:openttd:openttd:0.1.1
cpe:/a:openttd:openttd:0.3.2.1
cpe:/a:openttd:openttd:0.3.0
cpe:/a:openttd:openttd:0.3.2
cpe:/a:openttd:openttd:0.1.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2763
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2763
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-042
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200509-03.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200509-03
http://bugs.gentoo.org/show_bug.cgi?id=102631
(PATCH)  MISC  http://bugs.gentoo.org/show_bug.cgi?id=102631
http://www.vupen.com/english/advisories/2005/1640
(UNKNOWN)  VUPEN  ADV-2005-1640

- 漏洞信息

OpenTTD 多个格式化字符串漏洞
高危 格式化字符串
2005-09-06 00:00:00 2005-10-20 00:00:00
远程  
        OpenTTD是一款开放源码的游戏引擎。
        OpenTTD before 0.4.0.1之前的版本中存在多个格式化字符串漏洞。这使得远程攻击者可以造成服务拒绝(崩溃)并可能借助于未明方法执行任意代码。

- 公告与补丁

        暂无数据

- 漏洞信息 (F39860)

Gentoo Linux Security Advisory 200509-3 (PacketStormID:F39860)
2005-09-07 00:00:00
Gentoo  security.gentoo.org
advisory,vulnerability
linux,gentoo
CVE-2005-2763
[点击下载]

Gentoo Linux Security Advisory GLSA 200509-03 - Alexey Dobriyan discovered several format string vulnerabilities in OpenTTD. Versions less than 0.4.0.1-r1 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200509-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: OpenTTD: Format string vulnerabilities
      Date: September 05, 2005
      Bugs: #102631
        ID: 200509-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

OpenTTD is vulnerable to format string vulnerabilities which may result
in remote execution of arbitrary code.

Background
==========

OpenTTD is an open source clone of the simulation game "Transport
Tycoon Deluxe" by Microprose.

Affected packages
=================

    -------------------------------------------------------------------
     Package                   /   Vulnerable   /           Unaffected
    -------------------------------------------------------------------
  1  games-simulation/openttd     < 0.4.0.1-r1           >= 0.4.0.1-r1

Description
===========

Alexey Dobriyan discovered several format string vulnerabilities in
OpenTTD.

Impact
======

A remote attacker could exploit these vulnerabilities to crash the
OpenTTD server or client and possibly execute arbitrary code with the
rights of the user running OpenTTD.

Workaround
==========

There are no known workarounds at this time.

Resolution
==========

All OpenTTD users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose
">=games-simulation/openttd-0.4.0.1-r1"

References
==========

  [ 1 ] CAN-2005-2763
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2763

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200509-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
    

- 漏洞信息

19620
OpenTTD network.c Format String
Remote / Network Access, Local / Remote, Context Dependent Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Vendor Verified

- 漏洞描述

OpenTTD contains a flaw that may allow a malicious user to issue format commands to the network.c program. It is possible that the flaw may terminate the application (DoS) or execute commands, resulting in a loss of confidentiality, or availability.

- 时间线

2005-09-06 2005-08-15
Unknow Unknow

- 解决方案

Upgrade to version 4.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

OpenTTD Multiple Unspecified Format String Vulnerabilities
Input Validation Error 14738
Yes No
2005-09-05 12:00:00 2009-07-12 05:06:00
Discovered by Alexey Dobriyan.

- 受影响的程序版本

OpenTTD OpenTTD 0.4 .0.1
Gentoo Linux

- 漏洞讨论

OpenTTD is prone to multiple format string vulnerabilities. Successful exploitation could cause the application to fail or allow remote arbitrary code execution.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Gentoo has released advisory GLSA 200509-03 to address this issue. To obtain fixes, execute the following as the superuser:

emerge --sync
emerge --ask --oneshot --verbose ">=games-simulation/openttd-0.4.0.1-r1"

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站