CVE-2005-2723
CVSS7.5
发布时间 :2005-08-30 07:45:00
修订时间 :2016-10-17 23:29:45
NMCO    

[原文]SQL injection vulnerability in auth.php in PaFileDB 3.1, when authmethod is set to cookies, allows remote attackers to execute arbitrary SQL commands via the username value in the pafiledbcookie cookie.


[CNNVD]PAFileDB 'auth.php' SQL注入漏洞(CNNVD-200508-310)

        paFileDB是一款文件管理脚本,允许版主管理站点下载文件数据库,还可以编辑和删除文件。
        paFileDB的'/includes/admin/auth.php'文件中存在SQL注入漏洞,远程攻击者可以利用这个漏洞入侵基础数据库系统。
        起因是没有正确的过滤用户输入:
        [code]
        if ($authmethod == "cookies") {
        echo "authmethod = cookies\n";
        $cdata = explode("|", $pafiledbcookie);
        $ip = $cdata[0];
        $user = $cdata[1];
        $pass = $cdata[2];
        echo "ip = $ip, user = $user, pass = $pass\n";
        }
        if (!empty($user)) {
        echo "user not emtpy\n";
        $admin = $pafiledb_sql->query($db, "SELECT * FROM $db[prefix]_admin WHERE admin_username = '$user'", 1);
        $adminip = getenv ("REMOTE_ADDR");
        $md5ip = md5($adminip);
        if ($pass == $admin[admin_password] & & $md5ip == $ip) {
        $logged = 1;
        }
        } else {
        echo "user empty\n";
        $logged = 0;
        }
        [/code]

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2723
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2723
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-310
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112490781927680&w=2
(UNKNOWN)  BUGTRAQ  20050824 PaFileDB 3.1 - SQL-Injection
http://www.security-project.org/projects/board/showthread.php?t=947
(VENDOR_ADVISORY)  MISC  http://www.security-project.org/projects/board/showthread.php?t=947
http://www.securityfocus.com/bid/14654
(UNKNOWN)  BID  14654
http://xforce.iss.net/xforce/xfdb/21988
(UNKNOWN)  XF  pafiledb-auth-sql-injection(21988)

- 漏洞信息

PAFileDB 'auth.php' SQL注入漏洞
高危 SQL注入
2005-08-30 00:00:00 2005-10-20 00:00:00
远程  
        paFileDB是一款文件管理脚本,允许版主管理站点下载文件数据库,还可以编辑和删除文件。
        paFileDB的'/includes/admin/auth.php'文件中存在SQL注入漏洞,远程攻击者可以利用这个漏洞入侵基础数据库系统。
        起因是没有正确的过滤用户输入:
        [code]
        if ($authmethod == "cookies") {
        echo "authmethod = cookies\n";
        $cdata = explode("|", $pafiledbcookie);
        $ip = $cdata[0];
        $user = $cdata[1];
        $pass = $cdata[2];
        echo "ip = $ip, user = $user, pass = $pass\n";
        }
        if (!empty($user)) {
        echo "user not emtpy\n";
        $admin = $pafiledb_sql->query($db, "SELECT * FROM $db[prefix]_admin WHERE admin_username = '$user'", 1);
        $adminip = getenv ("REMOTE_ADDR");
        $md5ip = md5($adminip);
        if ($pass == $admin[admin_password] & & $md5ip == $ip) {
        $logged = 1;
        }
        } else {
        echo "user empty\n";
        $logged = 0;
        }
        [/code]

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.phparena.net

- 漏洞信息

18974
paFileDB auth.php pafiledbcookie Cookie SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

- 时间线

2005-08-24 Unknow
2005-08-24 Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站