CVE-2005-2691
CVSS7.5
发布时间 :2005-08-24 00:00:00
修订时间 :2008-09-05 16:52:26
NMCO    

[原文]includes/common.php in RunCMS 1.2 and earlier calls the extract function with EXTR_OVERWRITE on HTTP POST variables, which allows remote attackers to overwrite arbitrary variables, possibly allowing execution of arbitrary code.


[CNNVD]RunCMS 'common.php' 任意代码执行漏洞(CNNVD-200508-280)

        RunCMS 1.2及其早期版本中的includes/common.php页面调用extract函数(其输出类型为EXTR_OVERWRITE)作用于HTTP POST变量。这使得远程攻击者可以重写任意变量,并可能执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:runcms:runcms:1.1a
cpe:/a:runcms:runcms:1.2
cpe:/a:runcms:runcms:1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2691
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2691
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-280
(官方数据源) CNNVD

- 其它链接及资源

http://www.gulftech.org/?node=research&article_id=00094-08192005
(VENDOR_ADVISORY)  MISC  http://www.gulftech.org/?node=research&article_id=00094-08192005
http://secunia.com/advisories/16514
(VENDOR_ADVISORY)  SECUNIA  16514

- 漏洞信息

RunCMS 'common.php' 任意代码执行漏洞
高危 未知
2005-08-24 00:00:00 2005-10-20 00:00:00
远程  
        RunCMS 1.2及其早期版本中的includes/common.php页面调用extract函数(其输出类型为EXTR_OVERWRITE)作用于HTTP POST变量。这使得远程攻击者可以重写任意变量,并可能执行任意代码。

- 公告与补丁

        

- 漏洞信息

18907
RunCMS common.php Arbitrary Variable Overwrite
Remote / Network Access

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-08-19 Unknow
2005-08-19 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站