CVE-2005-2690
CVSS7.5
发布时间 :2005-08-24 00:00:00
修订时间 :2008-09-05 16:52:26
NMCO    

[原文]SQL injection vulnerability in the Downloads module in PostNuke 0.760-RC4b allows PostNuke administrators to execute arbitrary SQL commands via the show parameter to dl-viewdownload.php.


[CNNVD]PostNuke 'dl-viewdownload.php' SQL注入漏洞(CNNVD-200508-277)

        PostNuke是一款开放源码、开放开发的内容管理系统(CMS)。
        PostNuke中存在SQL注入漏洞,起因是没有正确的过滤用户输入。漏洞具体存在于"modules/Downloads/dl-viewdownload.php"。
        - --------
        if ($show!="") {
         $perpage = $show;
         } else {
         $show=$perpage;
         }
        ...
        $result = & $dbconn->SelectLimit($sql,$perpage,$min);
        - --------
        成功利用这个漏洞的攻击者可以执行任意SQL命令。但必需拥有管理权限才能利用这个漏洞,因此影响并不严重。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2690
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2690
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-277
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14636
(UNKNOWN)  BID  14636
http://www.securityfocus.com/archive/1/408818
(VENDOR_ADVISORY)  BUGTRAQ  20050822 [SECURITYREASON.COM] Multiple vulnerabilities in PostNuke 0.760-RC4b=>x cXIb8O3.15

- 漏洞信息

PostNuke 'dl-viewdownload.php' SQL注入漏洞
高危 SQL注入
2005-08-24 00:00:00 2006-04-07 00:00:00
远程  
        PostNuke是一款开放源码、开放开发的内容管理系统(CMS)。
        PostNuke中存在SQL注入漏洞,起因是没有正确的过滤用户输入。漏洞具体存在于"modules/Downloads/dl-viewdownload.php"。
        - --------
        if ($show!="") {
         $perpage = $show;
         } else {
         $show=$perpage;
         }
        ...
        $result = & $dbconn->SelectLimit($sql,$perpage,$min);
        - --------
        成功利用这个漏洞的攻击者可以执行任意SQL命令。但必需拥有管理权限才能利用这个漏洞,因此影响并不严重。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.postnuke.com/

- 漏洞信息

18970
PostNuke dl-viewdownload.php show Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-08-22 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站