发布时间 :2005-10-14 06:02:00
修订时间 :2011-03-07 21:24:50

[原文]Format string vulnerability in the ParseBannerAndCapability function in main.c for up-imapproxy 1.2.3 and 1.2.4 allows remote IMAP servers to execute arbitrary code via format string specifiers in a banner or capability line.

[CNNVD]Up IMAPproxy 格式化字符串漏洞(CNNVD-200510-093)

        ImapProxy 是一个和webmail配合使用的IMAP缓存代理服务器。
        up-imapproxy 1.2.3和1.2.4的main.c中的ParseBannerAndCapability函数存在格式化字符串漏洞。远程IMAP服务器可以借助banner或capability line中的格式化字符串说明符执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2005-2015
(UNKNOWN)  VUPEN  ADV-2005-2014
(UNKNOWN)  BID  15048

- 漏洞信息

Up IMAPproxy 格式化字符串漏洞
高危 格式化字符串
2005-10-14 00:00:00 2005-10-20 00:00:00
        ImapProxy 是一个和webmail配合使用的IMAP缓存代理服务器。
        up-imapproxy 1.2.3和1.2.4的main.c中的ParseBannerAndCapability函数存在格式化字符串漏洞。远程IMAP服务器可以借助banner或capability line中的格式化字符串说明符执行任意代码。

- 公告与补丁

        up-imapproxy up-imapproxy 1.2.3
        Debian imapproxy_1.2.3-1sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        Debian imapproxy_1.2.3-1sarge1_sparc.deb
        Debian GNU/Linux 3.1 alias sarge

- 漏洞信息 (F40557)

Debian Linux Security Advisory 852-1 (PacketStormID:F40557)
2005-10-11 00:00:00

Debian Security Advisory DSA 852-1 - Steve Kemp discovered two format string vulnerabilities in up-imapproxy, an IMAP protocol proxy, which may lead remote attackers to the execution of arbitrary code.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 852-1                                        Martin Schulze
October 9th, 2005             
- --------------------------------------------------------------------------

Package        : up-imapproxy
Vulnerability  : format string vulnerability
Problem type   : remote
Debian-specific: no
CVE ID         : CAN-2005-2661

Steve Kemp discovered two format string vulnerabilities in
up-imapproxy, an IMAP protocol proxy, which may lead remote attackers
to the execution of arbitrary code.

The old stable distribution (woody) is not affected by these problems.

For the stable distribution (sarge) this problem has been fixed in
version 1.2.3-1sarge1.

For the unstable distribution (sid) this problem has been fixed in
version 1.2.4-2.

We recommend that you upgrade your imapproxy package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:
      Size/MD5 checksum:      682 78dba7c28705cb90254b789abe2cc3a1
      Size/MD5 checksum:     7902 6e7e65e2e30c13f335e63ef7f0f48a25
      Size/MD5 checksum:   122991 ad4dafd1417903feb1e09ec569ff1ad5

  Alpha architecture:
      Size/MD5 checksum:    54064 67b3d4d2ac2e723937470e69ba2d25a3

  AMD64 architecture:
      Size/MD5 checksum:    50824 d6b14cb566d18868646a4f3bdd3c5104

  ARM architecture:
      Size/MD5 checksum:    49412 471d5f7d34c4ceea4b74918fe106645f

  Intel IA-32 architecture:
      Size/MD5 checksum:    49214 bd66a0d4f2de5e2fa33172a278cc417e

  Intel IA-64 architecture:
      Size/MD5 checksum:    60708 4fd07ac2f2a2bed4d2d26dc7285b8f10

  HP Precision architecture:
      Size/MD5 checksum:    52104 815ce032df02d514b69736b8e8d96252

  Motorola 680x0 architecture:
      Size/MD5 checksum:    45480 6e9ee814ec65b0c76638ce2925bd4333

  Big endian MIPS architecture:
      Size/MD5 checksum:    50688 51b9b737a702aa0c997ca7536e4a99f5

  Little endian MIPS architecture:
      Size/MD5 checksum:    50808 6591b56e82523af03d3d3a5361fa30f9

  PowerPC architecture:
      Size/MD5 checksum:    52096 87ec6e99203a2390e89c66f713875ef3

  IBM S/390 architecture:
      Size/MD5 checksum:    49916 94e2c29d3fc612f21cb26b8d32ca4bd3

  Sun Sparc architecture:
      Size/MD5 checksum:    48326 d6795267e5b6f2263ad6538e8da70a14

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.4.1 (GNU/Linux)


Full-Disclosure - We believe in it.
Hosted and sponsored by Secunia -

- 漏洞信息

up-imapproxy ParseBannerAndCapability() Function Format String
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-10-09 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Up-IMAPProxy Multiple Unspecified Remote Format String Vulnerabilities
Input Validation Error 15048
Yes No
2005-10-10 12:00:00 2009-07-12 05:07:00
Discovery is credited to Steve Kemp.

- 受影响的程序版本

up-imapproxy up-imapproxy 1.2.4
up-imapproxy up-imapproxy 1.2.3
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
Gentoo Linux

- 漏洞讨论

up-IMAPProxy is reported prone to multiple unspecified remote format-string vulnerabilities.

Successful exploitation could cause the application to crash or to execute arbitrary code in the context of the application.

Specific details of these issues are not currently known. This BID will be updated when further information becomes available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

A proof of concept example is available:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

Please see the referenced advisories for more information and fixes.

up-imapproxy up-imapproxy 1.2.3

- 相关参考