CVE-2005-2657
CVSS4.6
发布时间 :2005-09-16 18:03:00
修订时间 :2008-09-05 16:52:20
NMCOPS    

[原文]Unknown vulnerability in common-lisp-controller 4.18 and earlier allows local users to gain privileges by compiling arbitrary code in the cache directory, which is executed by another user if the user has not run Common Lisp before.


[CNNVD]Common-Lisp-Controller缓存目录中任意代码注入漏洞(CNNVD-200509-147)

        Common Lisp 是一个通用用途的编程语言,而common-lisp-controller则是Common Lisp的源代码和编译管理器。
        common-lisp-controller 4.18以及较早版本中的未知漏洞,允许本地用户通过在cache目录中编译任意代码获得权限,从而如果用户之前未运行过Common Lisp,那么其他用户也可执行。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2657
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2657
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-147
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/22275
(PATCH)  XF  common-lisp-controller-cache-gain-priv(22275)
http://www.securityfocus.com/bid/14829
(PATCH)  BID  14829
http://www.debian.org/security/2005/dsa-811
(VENDOR_ADVISORY)  DEBIAN  DSA-811
http://secunia.com/advisories/16822/
(VENDOR_ADVISORY)  SECUNIA  16822

- 漏洞信息

Common-Lisp-Controller缓存目录中任意代码注入漏洞
中危 设计错误
2005-09-16 00:00:00 2005-10-20 00:00:00
本地  
        Common Lisp 是一个通用用途的编程语言,而common-lisp-controller则是Common Lisp的源代码和编译管理器。
        common-lisp-controller 4.18以及较早版本中的未知漏洞,允许本地用户通过在cache目录中编译任意代码获得权限,从而如果用户之前未运行过Common Lisp,那么其他用户也可执行。

- 公告与补丁

        暂无数据

- 漏洞信息 (F40037)

Debian Linux Security Advisory 811-1 (PacketStormID:F40037)
2005-09-14 00:00:00
Debian  debian.org
advisory,local
linux,debian
CVE-2005-2657
[点击下载]

Debian Security Advisory DSA 811-1 - A bug was discovered in common-lisp-controller, a Common Lisp source and compiler manager, that allows a local user to compile malicious code into a cache directory which is executed by another user if that user has not used Common Lisp before.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 811-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
September 14th, 2005                    http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : common-lisp-controller
Vulnerability  : design error
Problem type   : local
Debian-specific: no
CVE ID         : CAN-2005-2657

Fran    

- 漏洞信息

19385
common-lisp-controller Cache Directory Owership Weakness Privilege Escalation
Local Access Required Misconfiguration
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Common-lisp-controller allows a local attacker to insert malicious code into the cache directory. Due to a failure to check ownership of the cache directory, this code may be automatically executed by other users when they use common lisp for the first time.

- 时间线

2005-09-14 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.15sarge2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Common-Lisp-Controller Cache Arbitrary Code Injection Vulnerability
Design Error 14829
No Yes
2005-09-14 12:00:00 2009-07-12 05:06:00
This vulnerability was announced in the referenced Debian advisory.

- 受影响的程序版本

common-lisp-controller common-lisp-controller
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Gentoo Linux

- 漏洞讨论

common-lisp-controller is prone to an arbitrary code injection vulnerability.

Successful exploitation may facilitate privilege escalation; other attacks are also possible.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released revised security advisory DSA 811-2 detailing fixes to address this issue. The fixes mentioned in the first revision (DSA 811-1) was prone to an error that caused third-party programs to fail. Please see the revised advisory for the most recent information regarding fixes.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.


common-lisp-controller common-lisp-controller

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站