CVE-2005-2656
CVSS2.1
发布时间 :2005-09-06 19:03:00
修订时间 :2008-09-05 16:52:20
NMCOPS    

[原文]Polygen before 1.0.6 generates precompiled grammar objects with world-writable permissions, which allows local users to cause a denial of service (disk consumption) and possibly perform other unauthorized activities.


[CNNVD]PolyGen 本地拒绝服务漏洞(CNNVD-200509-036)

        Polygen是一款建模软件。
        Polygen 1.0.6之前的版本允许任何人都可以生成预编译的对象。这使得本地用户可以造成服务拒绝(磁盘耗费)并且可能执行其它未授权的操作。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2656
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2656
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-036
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2005/dsa-794
(VENDOR_ADVISORY)  DEBIAN  DSA-794
http://www.securityfocus.com/bid/14722
(UNKNOWN)  BID  14722

- 漏洞信息

PolyGen 本地拒绝服务漏洞
低危 设计错误
2005-09-06 00:00:00 2005-10-20 00:00:00
本地  
        Polygen是一款建模软件。
        Polygen 1.0.6之前的版本允许任何人都可以生成预编译的对象。这使得本地用户可以造成服务拒绝(磁盘耗费)并且可能执行其它未授权的操作。

- 公告与补丁

        暂无数据

- 漏洞信息 (F39815)

Debian Linux Security Advisory 794-1 (PacketStormID:F39815)
2005-09-05 00:00:00
Debian  debian.org
advisory,local
linux,debian
CVE-2005-2656
[点击下载]

Debian Security Advisory DSA 794-1 - Justin Rye noticed that polygen generates precompiled grammar objects world-writable, which can be exploited by a local attacker to at least fill up the filesystem.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 794-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
September 1st, 2005                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : polygen
Vulnerability  : programming error
Problem-Type   : local
Debian-specific: no
CVE ID         : CAN-2005-2656
Debian Bug     : 325468

Justin Rye noticed that polygen generates precompiled grammar objects
world-writable, which can be exploited by a local attacker to at least
fill up the filesystem.

The old stable distribution (woody) does not contain the polygen package.

For the stable distribution (sarge) this problem has been fixed in
version 1.0.6-7sarge1.

For the unstable distribution (sid) this problem has been fixed in
version 1.0.6-9.

We recommend that you upgrade your polygen package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/p/polygen/polygen_1.0.6-7sarge1.dsc
      Size/MD5 checksum:      624 5884af6c72cffb4715dec28af8f6dd6d
    http://security.debian.org/pool/updates/main/p/polygen/polygen_1.0.6-7sarge1.diff.gz
      Size/MD5 checksum:     3874 2d23ba087885b09cf130c8cbd1cb69ff
    http://security.debian.org/pool/updates/main/p/polygen/polygen_1.0.6.orig.tar.gz
      Size/MD5 checksum:   360877 f75f09a959069e6492845fb10f0d29e2

  Architecture independent components:

    http://security.debian.org/pool/updates/main/p/polygen/polygen-data_1.0.6-7sarge1_all.deb
      Size/MD5 checksum:   263626 f8fd3d92d9df8cab3a4e980e02af661b
    http://security.debian.org/pool/updates/main/p/polygen/polygen_1.0.6-7sarge1_all.deb
      Size/MD5 checksum:    85244 09cb354582c54eb20cb78d0912ee3eef


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDF1iKW5ql+IAeqTIRAsNTAKCoBCsKCv1xLQN57BejrGi3zwjY2wCeL58S
d5V7LxXzRD0c/Ufcod3LkjI=
=bdR8
-----END PGP SIGNATURE-----

    

- 漏洞信息

19236
Polygen Precompiled Grammar Object Permission Weakness Local DoS
Denial of Service
Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-09-01 Unknow
2005-09-01 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PolyGen Local Denial of Service Vulnerability
Design Error 14722
No Yes
2005-09-01 12:00:00 2009-07-12 05:06:00
Discovery is credited to Justin Rye.

- 受影响的程序版本

PolyGen PolyGen 1.0.6
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1

- 漏洞讨论

PolyGen is prone to a local denial of service vulnerability.

A local attacker can potentially cause a denial of service condition due to resource exhaustion.

PolyGen 1.0.6 is affected by this vulnerability.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Debian has released advisory DSA 794-1 to address this issue. Please see the referenced advisory for more information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.


PolyGen PolyGen 1.0.6

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站