CVE-2005-2655
CVSS10.0
发布时间 :2005-08-30 13:03:00
修订时间 :2008-09-05 16:52:20
NMCOPS    

[原文]lockmail in maildrop before 1.5.3 does not drop privileges before executing commands, which allows local users to gain privileges via command line arguments.


[CNNVD]Maildrop 'Lockmail' 本地提权漏洞(CNNVD-200508-319)

        maildrop 1.5.3之前的版本中的lockmail不能在执行命令之前删除权限。这使得本地用户可以借助于命令行参数获取权限。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:maildrop:maildrop:1.2
cpe:/a:maildrop:maildrop:1.5.0
cpe:/a:maildrop:maildrop:1.0
cpe:/a:maildrop:maildrop:0.63
cpe:/a:maildrop:maildrop:0.70
cpe:/a:maildrop:maildrop:1.3.9
cpe:/a:maildrop:maildrop:0.76
cpe:/a:maildrop:maildrop:1.3.7
cpe:/a:maildrop:maildrop:0.54
cpe:/a:maildrop:maildrop:1.3.4
cpe:/a:maildrop:maildrop:1.1
cpe:/a:maildrop:maildrop:0.54b
cpe:/a:maildrop:maildrop:1.3.8
cpe:/a:maildrop:maildrop:1.2.1
cpe:/a:maildrop:maildrop:0.99.2
cpe:/a:maildrop:maildrop:0.62
cpe:/a:maildrop:maildrop:0.74
cpe:/a:maildrop:maildrop:0.55
cpe:/a:maildrop:maildrop:0.50
cpe:/a:maildrop:maildrop:0.72
cpe:/a:maildrop:maildrop:0.99.1
cpe:/a:maildrop:maildrop:0.55c
cpe:/a:maildrop:maildrop:0.51
cpe:/a:maildrop:maildrop:1.4.0
cpe:/a:maildrop:maildrop:0.54a
cpe:/a:maildrop:maildrop:0.61
cpe:/a:maildrop:maildrop:0.73
cpe:/a:maildrop:maildrop:0.65
cpe:/a:maildrop:maildrop:1.5.2
cpe:/a:maildrop:maildrop:1.3.6
cpe:/a:maildrop:maildrop:0.64
cpe:/a:maildrop:maildrop:0.71
cpe:/a:maildrop:maildrop:1.5.1
cpe:/a:maildrop:maildrop:0.51c
cpe:/a:maildrop:maildrop:1.3.3
cpe:/a:maildrop:maildrop:0.60
cpe:/a:maildrop:maildrop:1.3.1
cpe:/a:maildrop:maildrop:0.55a
cpe:/a:maildrop:maildrop:1.3.5
cpe:/a:maildrop:maildrop:1.2.2
cpe:/a:maildrop:maildrop:0.51b
cpe:/a:maildrop:maildrop:0.75
cpe:/a:maildrop:maildrop:1.3.0
cpe:/a:maildrop:maildrop:0.55b

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2655
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2655
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-319
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2005/dsa-791
(VENDOR_ADVISORY)  DEBIAN  DSA-791

- 漏洞信息

Maildrop 'Lockmail' 本地提权漏洞
危急 设计错误
2005-08-30 00:00:00 2005-10-20 00:00:00
本地  
        maildrop 1.5.3之前的版本中的lockmail不能在执行命令之前删除权限。这使得本地用户可以借助于命令行参数获取权限。

- 公告与补丁

        暂无数据

- 漏洞信息 (F39715)

Debian Linux Security Advisory 791-1 (PacketStormID:F39715)
2005-08-31 00:00:00
Debian  debian.org
advisory,arbitrary
linux,debian
CVE-2005-2655
[点击下载]

Debian Security Advisory DSA 791-1 - Max Vozeler discovered that the lockmail program from maildrop, a simple mail delivery agent with filtering abilities, does not drop group privileges before executing commands given on the commandline, allowing an attacker to execute arbitrary commands under with group mail privileges.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 791-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
August 30th, 2005                       http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : maildrop
Vulnerability  : missing privilege release
Problem-Type   : local
Debian-specific: yes
CVE ID         : CAN-2005-2655
Debian Bug     : 325135

Max Vozeler discoveredt hat the lockmail program from maildrop, a
simple mail delivery agent with filtering abilities, does not drop
group privileges before executing commands given on the commandline,
allowing an attacker to execute arbitrary commands under with group
mail privileges.

The old stable distribution (woody) is not affected by this problem.

For the stable distribution (sarge) this problem has been fixed in
version 1.5.3-1.1sarge1.

For the unstable distribution (sid) this problem has been fixed in
version 1.5.3-2.

We recommend that you upgrade your maildrop package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1.dsc
      Size/MD5 checksum:      596 e76d7a43dde5122dbabd21b994a32f2f
    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1.diff.gz
      Size/MD5 checksum:    22819 3ec43b768cfb2c8b006c5c4a381afc3b
    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3.orig.tar.gz
      Size/MD5 checksum:  1009174 5c7727ddff120a339fb9658d6c553462

  Alpha architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_alpha.deb
      Size/MD5 checksum:   363330 5aa987d64b2d28961fb2b1e65b865ea3

  AMD64 architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_amd64.deb
      Size/MD5 checksum:   329170 29e4ae76fce86fa5c7b17be3fc06b07f

  ARM architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_arm.deb
      Size/MD5 checksum:   305936 c99c08496e5aa6f4e48f3cead6cd1041

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_i386.deb
      Size/MD5 checksum:   315316 45a21b635d79fd783a6a4b2ea8eeb0fb

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_ia64.deb
      Size/MD5 checksum:   405646 c2be65e5af7085deafd4c332d624f9b5

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_hppa.deb
      Size/MD5 checksum:   348108 400ddf8ee844b685e683893de2bc7186

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_m68k.deb
      Size/MD5 checksum:   294932 72e7e31ec6408f5a00012141718666d6

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_mips.deb
      Size/MD5 checksum:   348182 f66f3863c068e3f3897ee531f242f4ea

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_mipsel.deb
      Size/MD5 checksum:   348002 6b8b8047154a4aae6ae4a08a26c328a4

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_powerpc.deb
      Size/MD5 checksum:   326702 0b5a94cede67887ce474ca37cd48da54

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_s390.deb
      Size/MD5 checksum:   321620 d7c3b3acc5445e5ca53cf9986a837d81

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/m/maildrop/maildrop_1.5.3-1.1sarge1_sparc.deb
      Size/MD5 checksum:   307994 0ca7e53ae93ba472527eedda1d92490f


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDE/cJW5ql+IAeqTIRAsqCAJ0aMXh4p+2eBWHf7wsz0KnJWtLCvQCgs2Rg
OssvYmWIPLPpms4+pahxW48=
=i7hE
-----END PGP SIGNATURE-----

    

- 漏洞信息

19083
maildrop lockmail Privileged Local Command Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-08-30 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Maildrop Lockmail Local Privilege Escalation Vulnerability
Design Error 14696
No Yes
2005-08-30 12:00:00 2009-07-12 05:06:00
Max Vozeler is credited with the discovery of this issue.

- 受影响的程序版本

maildrop maildrop 1.5.3
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1

- 漏洞讨论

Lockmail is affected by a local privilege escalation vulnerability.

A local attacker can execute arbitrary commands with group mail privileges.

Maildrop 1.5.3 is affected by this issue. Other versions may be vulnerable as well.

- 漏洞利用

An exploit is not required.

- 解决方案

Debian has released advisory DSA 791-1 to address this issue. Please see the referenced advisory for more information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站