CVE-2005-2636
CVSS7.5
发布时间 :2005-08-23 00:00:00
修订时间 :2016-10-17 23:29:11
NMCO    

[原文]SQL injection vulnerability in lib-view-direct.inc.php in phpAdsNew and phpPgAds before 2.0.6 allows remote attackers to execute arbitrary SQL commands via the clientid parameter.


[CNNVD]phpAdsNew 'Lib-View-Direct.INC.PHP' SQL注入漏洞(CNNVD-200508-229)

        phpAdsNew和phpPgAds 2.0.6之前的版本中的lib-view-direct.inc.php页面存在SQL注入漏洞。这使得远程攻击者可以借助于clientid参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpadsnew:phpadsnew:2.0.5
cpe:/a:phppgads:phppgads:2.0.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2636
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2636
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-229
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112431497300344&w=2
(UNKNOWN)  BUGTRAQ  20050817 [PHPADSNEW-SA-2005-001] phpAdsNew and phpPgAds 2.0.6 fix multiple vulnerabilities
http://www.securityfocus.com/bid/14583
(PATCH)  BID  14583
http://www.securityfocus.com/bid/14588
(UNKNOWN)  BID  14588
http://xforce.iss.net/xforce/xfdb/21879
(VENDOR_ADVISORY)  XF  phppgads-libviewdirect-sql-injection(21879)

- 漏洞信息

phpAdsNew 'Lib-View-Direct.INC.PHP' SQL注入漏洞
高危 SQL注入
2005-08-23 00:00:00 2005-10-20 00:00:00
远程  
        phpAdsNew和phpPgAds 2.0.6之前的版本中的lib-view-direct.inc.php页面存在SQL注入漏洞。这使得远程攻击者可以借助于clientid参数执行任意SQL命令。

- 公告与补丁

        暂无数据

- 漏洞信息

18888
phpPgAds / phpAdsNew lib-view-direct.inc.php clientid Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

phpPgAds / phpAdsNew contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the lib-view-direct.inc.php script not properly sanitizing user-supplied input to the 'clientid' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-08-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站