CVE-2005-2635
CVSS5.0
发布时间 :2005-08-23 00:00:00
修订时间 :2016-10-17 23:29:10
NMCO    

[原文]Multiple directory traversal vulnerabilities in phpAdsNew and phpPgAds before 2.0.6 allow remote attackers to include arbitrary files via a .. (dot dot) in the (1) layerstyle parameter to adlayer.php or (2) language parameter to js-form.php.


[CNNVD]phpPgAds 多个目录遍历漏洞(CNNVD-200508-260)

        phpAdsNew和phpPgAds 2.0.6之前的版本中存在多个目录遍历漏洞。这使得远程攻击者可以借助于传递到adlayer.php的(1)layerstyle参数或传递到jsform.php的(2)language参数中的..(参数中包含'..')包含任意文件。(dot dot) in the (1) layerstyle parameter to adlayer.php or (2) language parameter to js-form.php.

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpadsnew:phpadsnew:2.0.5
cpe:/a:phppgads:phppgads:2.0.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2635
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2635
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-260
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112431497300344&w=2
(UNKNOWN)  BUGTRAQ  20050817 [PHPADSNEW-SA-2005-001] phpAdsNew and phpPgAds 2.0.6 fix multiple vulnerabilities
http://www.securityfocus.com/bid/14584
(PATCH)  BID  14584
http://www.securityreason.com/adv/phpAdsnew.SR.16.asc
(VENDOR_ADVISORY)  MISC  http://www.securityreason.com/adv/phpAdsnew.SR.16.asc
http://xforce.iss.net/xforce/xfdb/21880
(PATCH)  XF  phppgads-multiple-file-include(21880)

- 漏洞信息

phpPgAds 多个目录遍历漏洞
中危 路径遍历
2005-08-23 00:00:00 2005-10-20 00:00:00
远程  
        phpAdsNew和phpPgAds 2.0.6之前的版本中存在多个目录遍历漏洞。这使得远程攻击者可以借助于传递到adlayer.php的(1)layerstyle参数或传递到jsform.php的(2)language参数中的..(参数中包含'..')包含任意文件。(dot dot) in the (1) layerstyle parameter to adlayer.php or (2) language parameter to js-form.php.

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        phpPgAds phpPgAds 2.0.5
        phpPgAds phpPgAds-2.0.6.tar.gz
        http://prdownloads.sourceforge.net/phppgads/phpPgAds-2.0.6.tar.gz?download

- 漏洞信息

18886
phpPgAds / phpAdsNew adlayer.php layerstyle Parameter Traversal Local File Inclusion
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

phpPgAds / phpAdsNew contains a flaw that allows a remote attacker to read files outside of the web path. The issue is due to the adlayer.php script not properly sanitizing user input, specifically traversal style attacks (../../) supplied via the 'layerstyle' variable.

- 时间线

2005-08-17 Unknow
2005-08-17 Unknow

- 解决方案

Upgrade to version 2.0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站