CVE-2005-2608
CVSS4.3
发布时间 :2005-08-17 00:00:00
修订时间 :2008-09-05 16:52:12
NMCO    

[原文]SafeHTML before 1.3.5 does not properly filter script in UTF-7 and CSS comments, which allows remote attackers to conduct cross-site scripting (XSS) attacks in vulnerable applications that use SafeHTML.


[CNNVD]SafeHTML 多个跨站脚本漏洞(CNNVD-200508-174)

        SafeHTML 1.3.5之前的版本不能正确地过滤UTF-7和CSS注释中的脚本。这使得远程攻击者可以在使用SafeHTML的脆弱应用程序中进行跨站脚本攻击。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2608
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2608
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-174
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14574
(PATCH)  BID  14574
http://secunia.com/advisories/16427
(UNKNOWN)  SECUNIA  16427

- 漏洞信息

SafeHTML 多个跨站脚本漏洞
中危 跨站脚本
2005-08-17 00:00:00 2005-10-20 00:00:00
远程  
        SafeHTML 1.3.5之前的版本不能正确地过滤UTF-7和CSS注释中的脚本。这使得远程攻击者可以在使用SafeHTML的脆弱应用程序中进行跨站脚本攻击。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        SafeHTML SafeHTML 1.3.2
        SafeHTML safehtml-1.3.5.zip
        http://pixel-apes.com/download/safehtml-1.3.5.zip

- 漏洞信息

18743
SafeHTML UTF-7 XSS Unspecified Comments Handling Bypass
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Private

- 漏洞描述

SafeHTML contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the script in UTF-7 and CSS comments upon submission to the handling script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-08-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.3.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站