CVE-2005-2557
CVSS4.3
发布时间 :2005-09-28 17:03:00
修订时间 :2016-10-17 23:28:18
NMCOP    

[原文]Cross-site scripting (XSS) vulnerability in view_all_set.php in Mantis 0.19.0a1 through 1.0.0a3 allows remote attackers to inject arbitrary web script or HTML via the dir parameter, as identified by bug#0005959, and a different vulnerability than CVE-2005-3090.


[CNNVD]Mantis view_all_set.php跨站脚本攻击(XSS)漏洞(CNNVD-200509-277)

        Mantis是一个基于PHP技术的轻量级的开源缺陷跟踪系统,其功能与JIRA系统类似,都是以Web操作的形式提供项目管理及缺陷跟踪服务。在功能上可能没有JIRA那么专业,界面也没有JIRA漂亮,但在实用性上足以满足中小型项目的管理及跟踪。
        Mantis 0.19.0a1至1.0.0a3版本中的view_all_set.php脚本中存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过dir参数注入任意web脚本或HTML,dir参数由#0005959bug识别。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/o:debian:debian_linux:3.1::arm
cpe:/o:gentoo:linuxGentoo Linux
cpe:/o:debian:debian_linux:3.1::ppc
cpe:/o:debian:debian_linux:3.1::ia-32
cpe:/a:mantis:mantis:0.19.0_rc1
cpe:/o:debian:debian_linux:3.1::mipsel
cpe:/o:debian:debian_linux:3.1::alpha
cpe:/o:debian:debian_linux:3.1::ia-64
cpe:/a:mantis:mantis:0.19.0
cpe:/a:mantis:mantis:1.0.0a1
cpe:/o:debian:debian_linux:3.1::sparc
cpe:/a:mantis:mantis:0.19.1
cpe:/a:mantis:mantis:0.19.2
cpe:/a:mantis:mantis:1.0.0a3
cpe:/a:mantis:mantis:1.0.0a2
cpe:/o:debian:debian_linux:3.1::hppa
cpe:/o:debian:debian_linux:3.1::s-390
cpe:/o:debian:debian_linux:3.1::amd64
cpe:/o:debian:debian_linux:3.1::mips
cpe:/o:debian:debian_linux:3.1::m68k
cpe:/a:mantis:mantis:0.19.0a1
cpe:/a:mantis:mantis:0.19.0a2
cpe:/o:debian:debian_linux:3.1Debian Debian Linux 3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2557
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2557
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-277
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112786017426276&w=2
(UNKNOWN)  BUGTRAQ  20050926 Mantis Bugtracker - Remote Database Scanner and XSS Vulnerabilities
http://www.debian.org/security/2005/dsa-778
(VENDOR_ADVISORY)  DEBIAN  DSA-778
http://www.gentoo.org/security/en/glsa/glsa-200509-16.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200509-16
http://www.mantisbt.org/changelog.php
(UNKNOWN)  CONFIRM  http://www.mantisbt.org/changelog.php
http://www.securityfocus.com/bid/14604
(PATCH)  BID  14604
http://xforce.iss.net/xforce/xfdb/21958
(PATCH)  XF  mantis-bug-report-xss(21958)

- 漏洞信息

Mantis view_all_set.php跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2005-09-28 00:00:00 2005-10-25 00:00:00
远程  
        Mantis是一个基于PHP技术的轻量级的开源缺陷跟踪系统,其功能与JIRA系统类似,都是以Web操作的形式提供项目管理及缺陷跟踪服务。在功能上可能没有JIRA那么专业,界面也没有JIRA漂亮,但在实用性上足以满足中小型项目的管理及跟踪。
        Mantis 0.19.0a1至1.0.0a3版本中的view_all_set.php脚本中存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过dir参数注入任意web脚本或HTML,dir参数由#0005959bug识别。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        Mantis Mantis 0.19 .0a
        Mantis Mantis 1.0.0rc1
        http://www.mantisbt.org/download.php
        Mantis Mantis 0.19.1
        Mantis Mantis 1.0.0rc1
        http://www.mantisbt.org/download.php
        Mantis Mantis 0.19.2
        Mantis Mantis 1.0.0rc1
        http://www.mantisbt.org/download.php

- 漏洞信息 (F40242)

Gentoo Linux Security Advisory 200509-16 (PacketStormID:F40242)
2005-09-26 00:00:00
Gentoo  security.gentoo.org
advisory,vulnerability,xss,sql injection
linux,gentoo
CVE-2005-2556,CVE-2005-2557
[点击下载]

Gentoo Linux Security Advisory GLSA 200509-16 - Mantis fails to properly sanitize untrusted input before using it. This leads to an SQL injection and several cross-site scripting vulnerabilities. Versions less than 0.19.2 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200509-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Mantis: XSS and SQL injection vulnerabilities
      Date: September 24, 2005
      Bugs: #103308
        ID: 200509-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Mantis is affected by an SQL injection and several cross-site scripting
(XSS) vulnerabilities.

Background
==========

Mantis is a web-based bugtracking system written in PHP.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  www-apps/mantisbt      < 0.19.2                         >= 0.19.2

Description
===========

Mantis fails to properly sanitize untrusted input before using it. This
leads to an SQL injection and several cross-site scripting
vulnerabilities.

Impact
======

An attacker could possibly use the SQL injection vulnerability to
access or modify information from the Mantis database. Furthermore the
cross-site scripting issues give an attacker the ability to inject and
execute malicious script code or to steal cookie-based authentication
credentials, potentially compromising the victim's browser.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Mantis users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/mantisbt-0.19.2"

References
==========

  [ 1 ] CAN-2005-2556
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2556
  [ 2 ] CAN-2005-2557
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2557
  [ 3 ] Secunia Advisory SA16506
        http://secunia.com/advisories/16506/

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200509-16.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

    

- 漏洞信息 (F39527)

Debian Linux Security Advisory 778-1 (PacketStormID:F39527)
2005-08-24 00:00:00
Debian  debian.org
advisory,web,arbitrary,sql injection
linux,debian
CVE-2004-0718,CVE-2005-2556,CVE-2005-2557
[点击下载]

Debian Security Advisory DSA 778-1 - Two security related problems have been discovered in Mantis, a web-based bug tracking system. The bugs related to arbitrary HTML and SQL injection flaws.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 778-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
August 19th, 2005                       http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : mantis
Vulnerability  : missing input sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2005-2556 CAN-2005-2557

Two security related problems have been discovered in Mantis, a
web-based bug tracking system.  The Common Vulnerabilities and
Exposures project identifies the following problems:

CAN-2005-2556

    A remote attacker could insert arbitrary SQL code into SQL
    statements.

CAN-2005-2557

    A remote attacker was able to insert arbitrary HTML code bug
    reports, hence, cross site scripting.

The old stable distribution (woody) does not seem to be affected by
these problems.

For the stable distribution (sarge) these problems have been fixed in
version 0.19.2-4.

For the unstable distribution (sid) these problems have been fixed in
version 0.19.2-4.

We recommend that you upgrade your mantis package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-4.dsc
      Size/MD5 checksum:      568 645a849f54cada06624b040ca106310f
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-4.diff.gz
      Size/MD5 checksum:    34601 311c66f058bfd06ef02d97dc0dad4880
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2.orig.tar.gz
      Size/MD5 checksum:  1298615 042c42c6de3bc536181391c1e9b25db3

  Architecture independent components:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-4_all.deb
      Size/MD5 checksum:   895224 afa2f33377b412779d5710e94b5f68e3


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDBeXcW5ql+IAeqTIRAnZVAKCz19oHpGJt//rRjb6PaPkKGnlQFACfTK4j
kveWIZjiSoKyZ1d8A8xetEA=
=iS8/
-----END PGP SIGNATURE-----

    

- 漏洞信息

18901
Mantis view_all_set.php dir Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-08-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.0rc1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站