CVE-2005-2549
CVSS7.5
发布时间 :2005-08-12 00:00:00
修订时间 :2016-10-17 23:28:13
NMCOPS    

[原文]Multiple format string vulnerabilities in Evolution 1.5 through 2.3.6.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via (1) full vCard data, (2) contact data from remote LDAP servers, or (3) task list data from remote servers.


[CNNVD]Evolution 多个远程格式串处理漏洞(CNNVD-200508-109)

        Evolution是个人和工作组信息管理解决方案,可使用在Linux和Unix操作系统下,集成Email、日历、会议安排、联系人管理等功能。
        Evolution在处理远程来源数据时存在多个格式串漏洞,可能导致崩溃或执行任意汇编语言代码,具体如下:
        1) 在浏览邮件消息附带的完整vCard数据时会出现格式串漏洞。在打开右击消息时,仅会显示vCard部分字段的压缩视图。如果用户点击"显示完整vCard"或执行类似操作时就会触发这个漏洞。
        2) 在显示远程LDAP服务器的联络数据时会出现格式串漏洞。
        3) 在显示远程服务器的任务列表数据时会出现格式串漏洞。
        4) 用户进入Calendars选项卡保存任务列表数据时会出现格式串漏洞。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:gnome:evolution:2.2
cpe:/a:gnome:evolution:2.3.3
cpe:/a:gnome:evolution:2.3.4
cpe:/a:gnome:evolution:1.5
cpe:/a:gnome:evolution:2.3.2
cpe:/a:gnome:evolution:2.3.5
cpe:/a:gnome:evolution:2.0
cpe:/a:gnome:evolution:2.3.6.1
cpe:/a:gnome:evolution:2.1
cpe:/a:gnome:evolution:2.3.1

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9553Multiple format string vulnerabilities in Evolution 1.5 through 2.3.6.1 allow remote attackers to cause a denial of service (crash) and poss...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2549
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2549
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-109
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=full-disclosure&m=112368237712032&w=2
(UNKNOWN)  FULLDISC  20050810 Evolution multiple remote format string bugs
http://www.debian.org/security/2006/dsa-1016
(UNKNOWN)  DEBIAN  DSA-1016
http://www.mandriva.com/security/advisories?name=MDKSA-2005:141
(UNKNOWN)  MANDRIVA  MDKSA-2005:141
http://www.novell.com/linux/security/advisories/2005_54_evolution.html
(UNKNOWN)  SUSE  SUSE-SA:2005:054
http://www.redhat.com/archives/fedora-announce-list/2005-August/msg00031.html
(UNKNOWN)  FEDORA  FEDORA-2005-743
http://www.redhat.com/support/errata/RHSA-2005-267.html
(UNKNOWN)  REDHAT  RHSA-2005:267
http://www.securityfocus.com/archive/1/407789
(UNKNOWN)  BUGTRAQ  20050810 Evolution multiple remote format string bugs
http://www.securityfocus.com/bid/14532
(UNKNOWN)  BID  14532
http://www.sitic.se/eng/advisories_and_recommendations/sa05-001.html
(UNKNOWN)  MISC  http://www.sitic.se/eng/advisories_and_recommendations/sa05-001.html
http://www.ubuntulinux.org/support/documentation/usn/usn-166-1
(UNKNOWN)  UBUNTU  USN-166-1

- 漏洞信息

Evolution 多个远程格式串处理漏洞
高危 格式化字符串
2005-08-12 00:00:00 2005-10-20 00:00:00
远程  
        Evolution是个人和工作组信息管理解决方案,可使用在Linux和Unix操作系统下,集成Email、日历、会议安排、联系人管理等功能。
        Evolution在处理远程来源数据时存在多个格式串漏洞,可能导致崩溃或执行任意汇编语言代码,具体如下:
        1) 在浏览邮件消息附带的完整vCard数据时会出现格式串漏洞。在打开右击消息时,仅会显示vCard部分字段的压缩视图。如果用户点击"显示完整vCard"或执行类似操作时就会触发这个漏洞。
        2) 在显示远程LDAP服务器的联络数据时会出现格式串漏洞。
        3) 在显示远程服务器的任务列表数据时会出现格式串漏洞。
        4) 用户进入Calendars选项卡保存任务列表数据时会出现格式串漏洞。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://ftp.gnome.org/pub/gnome/sources/evolution/

- 漏洞信息 (F39563)

Gentoo Linux Security Advisory 200508-12 (PacketStormID:F39563)
2005-08-24 00:00:00
Gentoo  security.gentoo.org
advisory,remote
linux,gentoo
CVE-2005-2549,CVE-2005-2550
[点击下载]

Gentoo Linux Security Advisory GLSA 200508-12 - Ulf Harnhammar discovered that Evolution is vulnerable to format string bugs when viewing attached vCards and when displaying contact information from remote LDAP servers or task list data from remote servers (CVE-2005-2549). He also discovered that Evolution fails to handle special calendar entries if the user switches to the Calendars tab (CVE-2005-2550). Versions less than 2.2.3-r3 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200508-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Evolution: Format string vulnerabilities
      Date: August 23, 2005
      Bugs: #102051
        ID: 200508-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Evolution is vulnerable to format string vulnerabilities which may
result in remote execution of arbitrary code.

Background
==========

Evolution is a GNOME groupware application.

Affected packages
=================

    -------------------------------------------------------------------
     Package                /  Vulnerable  /                Unaffected
    -------------------------------------------------------------------
  1  mail-client/evolution     < 2.2.3-r3                  >= 2.2.3-r3

Description
===========

Ulf Harnhammar discovered that Evolution is vulnerable to format string
bugs when viewing attached vCards and when displaying contact
information from remote LDAP servers or task list data from remote
servers (CAN-2005-2549). He also discovered that Evolution fails to
handle special calendar entries if the user switches to the Calendars
tab (CAN-2005-2550).

Impact
======

An attacker could attach specially crafted vCards to emails or setup
malicious LDAP servers or calendar entries which would trigger the
format string vulnerabilities when viewed or accessed from Evolution.
This could potentially result in the execution of arbitrary code with
the rights of the user running Evolution.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Evolution users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-client/evolution-2.2.3-r3"

References
==========

  [ 1 ] CAN-2005-2549
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2549
  [ 2 ] CAN-2005-2550
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2550
  [ 3 ] SITIC Vulnerability Advisory SA05-001
        http://www.sitic.se/eng/advisories_and_recommendations/sa05-001.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200508-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
    

- 漏洞信息

18687
Evolution vCard Attachment Format String
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity

- 漏洞描述

- 时间线

2005-08-10 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.3.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

GNOME Evolution Multiple Format String Vulnerabilities
Input Validation Error 14532
Yes No
2005-08-10 12:00:00 2006-12-20 08:28:00
Discovery is credited to Ulf Harnhammar for SITIC.

- 受影响的程序版本

Ubuntu Ubuntu Linux 5.0 4 powerpc
Ubuntu Ubuntu Linux 5.0 4 i386
Ubuntu Ubuntu Linux 5.0 4 amd64
Ubuntu Ubuntu Linux 4.1 ppc
Ubuntu Ubuntu Linux 4.1 ia64
Ubuntu Ubuntu Linux 4.1 ia32
SuSE SUSE Linux Enterprise Server 8
+ Linux kernel 2.4.21
+ Linux kernel 2.4.19
SGI ProPack 3.0 SP6
S.u.S.E. SuSE Linux Standard Server 8.0
S.u.S.E. SuSE Linux School Server for i386
S.u.S.E. SUSE LINUX Retail Solution 8.0
S.u.S.E. Open-Enterprise-Server 9.0
S.u.S.E. Novell Linux Desktop 9.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Professional 7.3
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux Enterprise Server for S/390 9.0
S.u.S.E. Linux Enterprise Server 9
S.u.S.E. Linux Desktop 1.0
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Desktop 4.0
RedHat Desktop 3.0
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Mandriva Linux Mandrake 10.1 x86_64
Mandriva Linux Mandrake 10.1
Mandriva Linux Mandrake 10.0 AMD64
Mandriva Linux Mandrake 10.0
MandrakeSoft Corporate Server 3.0 x86_64
MandrakeSoft Corporate Server 3.0
GNOME Evolution 2.3.6 .1
GNOME Evolution 2.3.6
GNOME Evolution 2.3.5
GNOME Evolution 2.3.4
GNOME Evolution 2.3.3
GNOME Evolution 2.3.2
GNOME Evolution 2.3.1
GNOME Evolution 2.2.1
GNOME Evolution 2.2
GNOME Evolution 2.1
GNOME Evolution 2.0.4
GNOME Evolution 2.0.1
GNOME Evolution 2.0
GNOME Evolution 1.5
GNOME Evolution 1.0.5
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
Conectiva Linux 10.0
GNOME Evolution 2.3.7

- 不受影响的程序版本

GNOME Evolution 2.3.7

- 漏洞讨论

Evolution is affected by multiple format-string vulnerabilities.

These issues can allow remote attackers to execute arbitrary code in the context of the client.

Evolution versions 1.5 to 2.3.6.1 are affected.

- 漏洞利用


Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案


Please see the referenced vendor advisories for information on updates.


GNOME Evolution 1.0.5

GNOME Evolution 1.5

GNOME Evolution 2.0

GNOME Evolution 2.0.1

GNOME Evolution 2.0.4

GNOME Evolution 2.2

SGI ProPack 3.0 SP6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站