CVE-2005-2536
CVSS7.5
发布时间 :2005-08-10 00:00:00
修订时间 :2008-09-05 16:52:01
NMCOPS    

[原文]pstotext before 1.8g does not properly use the "-dSAFER" option when calling Ghostscript to extract plain text from PostScript and PDF files, which allows remote attackers to execute arbitrary commands via a malicious PostScript file.


[CNNVD]PSToText 任意代码执行漏洞(CNNVD-200508-095)

        当调用Ghostscript从PostScript和PDF文件中提取纯文本时,Pstotext 1.8g之前的版本不能正确地使用"-dSAFER"选项。这使得远程攻击者可以借助于恶意PostScript文件执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2536
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2536
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-095
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200507-29.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200507-29
http://secunia.com/advisories/16183/
(VENDOR_ADVISORY)  SECUNIA  16183
http://xforce.iss.net/xforce/xfdb/21498
(UNKNOWN)  XF  pstotext-dsafer-command-execution(21498)
http://www.securityfocus.com/bid/14378
(UNKNOWN)  BID  14378
http://www.debian.org/security/2005/dsa-792
(UNKNOWN)  DEBIAN  DSA-792
http://secunia.com/advisories/16624
(UNKNOWN)  SECUNIA  16624
http://secunia.com/advisories/16305
(UNKNOWN)  SECUNIA  16305

- 漏洞信息

PSToText 任意代码执行漏洞
高危 设计错误
2005-08-10 00:00:00 2005-10-20 00:00:00
远程  
        当调用Ghostscript从PostScript和PDF文件中提取纯文本时,Pstotext 1.8g之前的版本不能正确地使用"-dSAFER"选项。这使得远程攻击者可以借助于恶意PostScript文件执行任意命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        pstotext pstotext 1.8
        Debian pstotext_1.8g-5woody1_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_alpha.deb
        Debian pstotext_1.8g-5woody1_arm.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_arm.deb
        Debian pstotext_1.8g-5woody1_hppa.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_hppa.deb
        Debian pstotext_1.8g-5woody1_i386.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_i386.deb
        Debian pstotext_1.8g-5woody1_ia64.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_ia64.deb
        Debian pstotext_1.8g-5woody1_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_m68k.deb
        Debian pstotext_1.8g-5woody1_mips.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_mips.deb
        Debian pstotext_1.8g-5woody1_mipsel.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_mipsel.deb
        Debian pstotext_1.8g-5woody1_powerpc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_powerpc.deb
        Debian pstotext_1.8g-5woody1_s390.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_s390.deb
        Debian pstotext_1.8g-5woody1_sparc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g- 5woody1_sparc.deb
        pstotext pstotext 1.9
        Debian pstotext_1.9-1sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_alpha.deb
        Debian pstotext_1.9-1sarge1_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_amd64.deb
        Debian pstotext_1.9-1sarge1_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_arm.deb
        Debian pstotext_1.9-1sarge1_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_hppa.deb
        Debian pstotext_1.9-1sarge1_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_i386.deb
        Debian pstotext_1.9-1sarge1_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_ia64.deb
        Debian pstotext_1.9-1sarge1_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_m68k.deb
        Debian pstotext_1.9-1sarge1_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_mips.deb
        Debian pstotext_1.9-1sarge1_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_mipsel.deb
        Debian pstotext_1.9-1sarge1_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_powerpc.deb
        Debian pstotext_1.9-1sarge1_s390.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_s390.deb
        Debian pstotext_1.9-1sarge1_sparc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1 sarge1_sparc.deb

- 漏洞信息 (F39763)

Debian Linux Security Advisory 792-1 (PacketStormID:F39763)
2005-09-01 00:00:00
Debian  debian.org
advisory
linux,debian
CVE-2005-2536
[点击下载]

Debian Security Advisory DSA 792-1 - Max Vozeler discovered that pstotext, a utility to extract text from PostScript and PDF files, did not execute ghostscript with the -dSAFER argument, which prevents potential malicious operations to happen.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 792-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
August 31st, 2005                       http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : pstotext
Vulnerability  : missing input sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2005-2536
BugTraq ID     : 14378
Debian Bug     : 319758

Max Vozeler discovered that pstotext, a utility to extract text from
PostScript and PDF files, did not execute ghostscript with the -dSAFER
argument, which prevents potential malicious operations to happen.

For the old stable distribution (woody) this problem has been fixed in
version 1.8g-5woody1.

For the stable distribution (sarge) this problem has been fixed in
version 1.9-1sarge1.

For the unstable distribution (sid) this problem has been fixed in
version 1.9-2.

We recommend that you upgrade your pstotext package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1.dsc
      Size/MD5 checksum:      569 5e4999fac3cb50533b8fa55fa9b8d839
    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1.diff.gz
      Size/MD5 checksum:     5551 e8656ca1e70907515dea96f646defbeb
    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g.orig.tar.gz
      Size/MD5 checksum:    36193 dfabf95fffea52cc03d8728617ca1b1e

  Alpha architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_alpha.deb
      Size/MD5 checksum:    33478 dc7994b7f762a99cda3f6e9eebfd5078

  ARM architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_arm.deb
      Size/MD5 checksum:    31158 64eb3bb5eaf13a54356bd8b55212ac93

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_i386.deb
      Size/MD5 checksum:    31140 ed687aa111ef4d56fd7b2fb220f8118a

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_ia64.deb
      Size/MD5 checksum:    37056 7ac97b49306cf896bb3d62b6b076ecb0

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_hppa.deb
      Size/MD5 checksum:    32884 6e7b79977d550e6981b0a6849face1b9

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_m68k.deb
      Size/MD5 checksum:    30124 5b23f0c04107d284c561d1621c4fd9d1

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_mips.deb
      Size/MD5 checksum:    32978 56283a3ef2931d2c4759c4c56218f83a

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_mipsel.deb
      Size/MD5 checksum:    32624 29ed7091abca377c4b91fa68d7bc48cb

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_powerpc.deb
      Size/MD5 checksum:    32082 c8b4af3f34d681f9dabe4ff31bf0434a

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_s390.deb
      Size/MD5 checksum:    31354 ce7f8f5b398350e9d779a847b7c5ef2f

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.8g-5woody1_sparc.deb
      Size/MD5 checksum:    35050 e6e74a1ccfc2cb7246911b2f0427609f


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1.dsc
      Size/MD5 checksum:      566 a4a25eaf8322a20742fb0eac628c096c
    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1.diff.gz
      Size/MD5 checksum:     7817 634b242dbb68cbb6cf1595e6fa390d0e
    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9.orig.tar.gz
      Size/MD5 checksum:    37461 64576e8a10ff5514e285d98b3898ae78

  Alpha architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_alpha.deb
      Size/MD5 checksum:    34084 82b71b24a4248ea05d243aa1d7b00e7c

  AMD64 architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_amd64.deb
      Size/MD5 checksum:    33670 b5911eb9b067b55315dadfba9c8cb590

  ARM architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_arm.deb
      Size/MD5 checksum:    32260 426147c50900aba089a9eb430e2094bb

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_i386.deb
      Size/MD5 checksum:    32632 e2f9a3859fe3061c85d4f1a54253062e

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_ia64.deb
      Size/MD5 checksum:    37624 76f3ed1bb870504692fe7fadbeb6e9b7

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_hppa.deb
      Size/MD5 checksum:    34282 7570594eef38d55ebb26e981c8de306b

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_m68k.deb
      Size/MD5 checksum:    31370 b9bd589dbbaf0d516cefb4f0b40397be

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_mips.deb
      Size/MD5 checksum:    34196 ac148736eaeedd368b6114c79c45b569

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_mipsel.deb
      Size/MD5 checksum:    33800 f9bad656d356e522daf2de44c0cc5f26

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_powerpc.deb
      Size/MD5 checksum:    33408 1b7b3cf7e04b3bf313d798ee822f7e92

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_s390.deb
      Size/MD5 checksum:    32948 b10976913ca43591166801bb9844f096

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/p/pstotext/pstotext_1.9-1sarge1_sparc.deb
      Size/MD5 checksum:    32992 c15517e727b7c38adec0f5f85282c430


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDFZL/W5ql+IAeqTIRArUzAJ95vyOxW+1CZU4UgSatkCljhARCmACfXkYb
gWLcQm6OQ8nZTV05XMkOg94=
=v5XA
-----END PGP SIGNATURE-----

    

- 漏洞信息

18251
pstotext Arbitrary Postscript Code Execution
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-07-24 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PSToText Arbitrary Code Execution Vulnerability
Design Error 14378
Yes No
2005-07-25 12:00:00 2009-07-12 04:06:00
Max Vozeler <xam@debian.org> reported this issue.

- 受影响的程序版本

pstotext pstotext 1.9
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Debian Linux 3.1
pstotext pstotext 1.8
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
Gentoo Linux

- 漏洞讨论

pstotext is susceptible to an arbitrary command execution vulnerability. This issue is due to a failure of the application to ensure that GhostScript is executed in a secure manner.

This issue allows attackers to create malicious PostScript files, that when parsed by the affected utility, allow arbitrary commands to be executed. This occurs in the context of the user running the affected utility.

- 漏洞利用

An exploit is not required.

- 解决方案

Gentoo has released advisory GLSA 200507-29 to address this issue. Please see the referenced advisory for more information. Gentoo users may carry out the following commands to update their computers:

emerge --sync
emerge --ask --oneshot --verbose ">=app-text/pstotext-1.8g-r1"

Debian has released advisory DSA 792-1 to address this issue. Please see the referenced advisory for more information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.


pstotext pstotext 1.8

pstotext pstotext 1.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站