发布时间 :2005-10-25 20:02:00
修订时间 :2008-09-05 16:51:59

[原文]Safari after 2.0 in Apple Mac OS X 10.3.9 allows remote attackers to bypass domain restrictions via crafted web archives that cause Safari to render them as if they came from a different site.

[CNNVD]Apple Safari 域限制绕过漏洞(CNNVD-200510-203)

        Apple Mac OS X 10.3.9中的Safari 2.0之后版本可以使远程攻击者借助特制的web档案,使Safari认为这些档案来自不同的站点,从而绕过域限制。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.3.9Apple Mac OS X 10.3.9
cpe:/a:apple:safari:2.0Apple Safari 2.0
cpe:/o:apple:mac_os_x_server:10.3.9Apple Mac OS X Server 10.3.9

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

Apple Safari 域限制绕过漏洞
中危 资料不足
2005-10-25 00:00:00 2005-10-31 00:00:00
        Apple Mac OS X 10.3.9中的Safari 2.0之后版本可以使远程攻击者借助特制的web档案,使Safari认为这些档案来自不同的站点,从而绕过域限制。

- 公告与补丁

        Apple Mac OS X 10.3.9
        Apple SecUpd2005-008Pan.dmg
        Apple Mac OS X Server 10.3.9
        Apple SecUpd2005-008Pan.dmg
        Apple Mac OS X 10.4.2
        Apple SecUpd2005-008Ti.dmg
        Apple Mac OS X Server 10.4.2
        Apple SecUpd2005-008Ti.dmg

- 漏洞信息

Apple Safari Remote Web Archive Processing XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Mac OS X contains an unspecified flaw that allows a remote cross site scripting attack. This flaw exists because Safari allows the viewing of remote web archives, which may be rendered as content from sites which did not serve them. This could allow a user to create a specially crafted archive that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-09-20 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Apple has released a patch (Security Update 2005-008) to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete