发布时间 :2005-08-19 00:00:00
修订时间 :2008-09-05 16:51:59

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Weblog Server in Mac OS X 10.4 to 10.4.2 allow remote attackers to inject arbitrary web script or HTML via unknown vectors.

[CNNVD]Mac OS X Weblog Server多个跨站脚本攻击漏洞(CNNVD-200508-193)

        Mac OS X是苹果家族计算机所使用的操作系统。
        Mac OS X 10.4直至 10.4.2版本的Weblog Server存在多个跨站脚本攻击漏洞。远程攻击者可以借助未明向量执行任意的WEB脚本和HTML.

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.4.2Apple Mac OS X 10.4.2
cpe:/o:apple:mac_os_x:10.4Apple Mac OS X 10.4
cpe:/a:apple:weblog_serverApple Weblog Server
cpe:/o:apple:mac_os_x:10.4.1Apple Mac OS X 10.4.1

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

Mac OS X Weblog Server多个跨站脚本攻击漏洞
中危 跨站脚本
2005-08-19 00:00:00 2005-10-20 00:00:00
        Mac OS X是苹果家族计算机所使用的操作系统。
        Mac OS X 10.4直至 10.4.2版本的Weblog Server存在多个跨站脚本攻击漏洞。远程攻击者可以借助未明向量执行任意的WEB脚本和HTML.

- 公告与补丁


- 漏洞信息 (F39428)

Exploit Labs Security Advisory 2005.10 (PacketStormID:F39428)
2005-08-17 00:00:00
Donnie Werner,Exploit Labs

Mac OS X Weblog Server version 10.4.0 is susceptible to cross site scripting attacks.

      - EXPL-A-2005-010 Advisory 039 -
                       - Mac OSX Server weblog -

Mac OSX 10.4.0 Weblog Server

Weblog Server, which simplifies the publication of Weblogs.
 It provides users with the ability to publish and syndicate
 their Web content using existing Web browsers, including
 Apple's own Safari software. Features include calendar-based
 navigation, user and group blogs and HTML, RSS, RSS2, RDF
 and ATOM protocols, as well as "Apple-designed blog themes."
 Weblog Server can also integrate with Open Directory, LDAP
 and access control lists for authentication.

1. XSS

Mac Server weblog comments does not properly filter
malicious script content. XSS my be inserted in the
author and comment body sections. The malicious script
is the rendered upon visitation and executed in the
context of the users brower.



input malicious script into author and comment sections in
the comment option on the weblog.
eg:<SCRIPT>alert(document.cookie);</SCRIPT> [cookie theft]
eg:<iframe src=""></iframe> [redirect]


vendor contact: June 11, 2005

patch released:

Weblog Server
CVE-ID: CAN-2005-2523
Available for: Mac OS X Server v10.4.2

patch available:

This vulnerability was discovered and researched by
Donnie Werner of exploitlabs

Donnie Werner

mail:   wood at
mail:   morning_wood at

Full-Disclosure - We believe in it.
Hosted and sponsored by Secunia -

- 漏洞信息

Apple Mac OS X Server Weblog Server Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Mac OS X contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate author and commentText variables upon submission to the Weblog script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-08-15 2005-06-11
2005-08-15 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Apple has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Apple Mac OS X Weblog Server Cross-Site Scripting Vulnerabilities
Input Validation Error 14569
Yes No
2005-08-15 12:00:00 2009-07-12 05:06:00
Discovery credited to Donnie Werner <> and Atsushi MATSUO.

- 受影响的程序版本

Apple Mac OS X Server 10.4.2
Apple Mac OS X Server 10.4.1
Apple Mac OS X Server 10.4
Apple Mac OS X 10.4.2
Apple Mac OS X 10.4.1
Apple Mac OS X 10.4

- 漏洞讨论

Apple Mac OS X Weblog Server is prone to cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

This issue was originally described in BID 14567 Apple Mac OS X Multiple Vulnerabilities. It is now being assigned its own BID.

- 漏洞利用

No exploit code is required. The following proof of concept URI's were provided:

input malicious script into author and comment sections in
the comment option on the weblog.
eg:&lt;SCRIPT&gt;alert(document.cookie);&lt;/SCRIPT&gt; [cookie theft]
eg:&lt;iframe src=""&gt;&lt;/iframe&gt; [redirect][bloguser]/?permalink=[blogentry]&amp;comment=y&amp;page=comments&amp;category=%2F&amp;author=[script]&amp;authorEmail=&amp;authorURL=&amp;commentText=[script]&amp;submit=Submit+Comment

- 解决方案

Apple has released fixes:

Apple Mac OS X 10.4.2

Apple Mac OS X Server 10.4.2

- 相关参考