CVE-2005-2499
CVSS2.1
发布时间 :2005-08-23 00:00:00
修订时间 :2010-08-21 00:31:33
NMCOS    

[原文]slocate before 2.7 does not properly process very long paths, which allows local users to cause a denial of service (updatedb exit and incomplete slocate database) via a certain crafted directory structure.


[CNNVD]SLocate 拒绝服务漏洞 (CNNVD-200508-226)

        Slocate 2.7之前的版本不能正确地处理过长路径。这使得本地用户可以借助于特定的精心设计的目录结构造成拒绝服务(更新数据库退出及不完整slocate数据库)。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:slocate:slocate:2.3
cpe:/a:slocate:slocate:2.2
cpe:/a:slocate:slocate:2.1
cpe:/a:slocate:slocate:2.5
cpe:/a:slocate:slocate:2.4
cpe:/a:slocate:slocate:2.6

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9538slocate before 2.7 does not properly process very long paths, which allows local users to cause a denial of service (updatedb exit and incom...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2499
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2499
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-226
(官方数据源) CNNVD

- 其它链接及资源

http://www.redhat.com/support/errata/RHSA-2005-747.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:747
http://xforce.iss.net/xforce/xfdb/22316
(UNKNOWN)  XF  slocate-directory-structure-dos(22316)
http://www.securityfocus.com/bid/14640
(UNKNOWN)  BID  14640
http://www.redhat.com/support/errata/RHSA-2005-346.html
(UNKNOWN)  REDHAT  RHSA-2005:346
http://www.redhat.com/support/errata/RHSA-2005-345.html
(UNKNOWN)  REDHAT  RHSA-2005:345
http://www.osvdb.org/19034
(UNKNOWN)  OSVDB  19034
http://securitytracker.com/id?1014751
(UNKNOWN)  SECTRACK  1014751

- 漏洞信息

SLocate 拒绝服务漏洞
低危 其他
2005-08-23 00:00:00 2005-10-20 00:00:00
本地  
        Slocate 2.7之前的版本不能正确地处理过长路径。这使得本地用户可以借助于特定的精心设计的目录结构造成拒绝服务(更新数据库退出及不完整slocate数据库)。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Conectiva Linux 10.0
        Conectiva nss_ldap-240-53589U10_1cl.i386.rpm
        Conectiva 10:
        ftp://atualizacoes.conectiva.com.br/10/RPMS/nss_ldap-240-53589U10_1cl.i386.rpm
        Conectiva nss_ldap-240-53589U10_1cl.i386.rpm
        Conectiva 10:
        nss_ldap-240-53589U10_1cl.i386.rpm
        Conectiva pam_ldap-180-47667U10_1cl.i386.rpm
        Conectiva 10:
        ftp://atualizacoes.conectiva.com.br/10/RPMS/pam_ldap-180-47667U10_1cl.i386.rpm
        slocate slocate 2.7
        Conectiva slocate-2.7-49374U10_1cl.i386.rpm
        Conectiva 10:
        ftp://atualizacoes.conectiva.com.br/10/RPMS/slocate-2.7-49374U10_1cl.i386.rpm
        Conectiva slocate-i18n-pt_BR-2.7-49374U10_1cl.i386.rpm
        Conectiva 10:
        ftp://atualizacoes.conectiva.com.br/10/RPMS/slocate-i18n-pt_BR-2.7-49374U10_1cl.i386.rpm
        Turbolinux slocate-2.7-8.i586.rpm
        Turbolinux 10 Desktop, Turbolinux 10 F..., Turbolinux Home, Turbolinux Multimedia, Turbolinux Personal
        ftp://ftp.turbolinux.co.jp/pub/TurboLinux/TurboLinux/ia32/Desktop/10/updates/RPMS/slocate-2.7-8.i586.rpm
        Turbolinux slocate-2.7-8.i586.rpm
        Turbolinux 10 Server
        ftp://ftp.turbolinux.co.jp/pub/TurboLinux/TurboLinux/ia32/Server/10/updates/RPMS/slocate-2.7-8.i586.rpmTurbolinux slocate-2.7-8.i586.rpm
        Turbolinux 7 Server
        ftp://ftp.turbolinux.co.jp/pub/TurboLinux/TurboLinux/ia32/Server/7/updates/RPMS/slocate-2.7-8.i586.rpm
        Turbolinux slocate-2.7-8.i586.rpm
        Turbolinux 8 Server
        ftp://ftp.turbolinux.co.jp/pub/TurboLinux/TurboLinux/ia32/Server/8/updates/RPMS/slocate-2.7-8.i586.rpm
        Turbolinux slocate-2.7-8.i586.rpm
        Turbolinux 7 Workstation
        ftp://ftp.turbolinux.co.jp/pub/TurboLinux/TurboLinux/ia32/Workstation/7/updates/RPMS/slocate-2.7-8.i586.rpm
        Turbolinux slocate-2.7-8.i586.rpm
        Turbolinux 8 Workstation
        ftp://ftp.turbolinux.co.jp/pub/TurboLinux/TurboLinux/ia32/Workstation/8/updates/RPMS/slocate-2.7-8.i586.rpm
        Turbolinux slocate-debug-2.7-8.i586.rpm
        Turbolinux 10 Server
        ftp://ftp.turbolinux.co.jp/pub/TurboLinux/TurboLinux/ia32/Server/10/updates/RPMS/slocate-debug-2.7-8.i586.rpm

- 漏洞信息

19034
slocate Crafted Long Directory Structure DoS
Denial of Service
Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-08-22 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SLocate Local Database Corruption Vulnerability
Failure to Handle Exceptional Conditions 14640
No Yes
2005-08-23 12:00:00 2009-07-12 05:06:00
The discoverer of this vulnerability is currently unknown. This issue was disclosed in a Mandriva advisory.

- 受影响的程序版本

Turbolinux Turbolinux Workstation 8.0
Turbolinux Turbolinux Workstation 7.0
Turbolinux Turbolinux Server 10.0
Turbolinux Turbolinux Server 8.0
Turbolinux Turbolinux Server 7.0
Turbolinux Turbolinux Desktop 10.0
Turbolinux Turbolinux 10 F...
TurboLinux Personal
TurboLinux Multimedia
Turbolinux Home
Turbolinux Appliance Server Workgroup Edition 1.0
Turbolinux Appliance Server Hosting Edition 1.0
Turbolinux Appliance Server 1.0 Workgroup Edition
Turbolinux Appliance Server 1.0 Hosting Edition
slocate slocate 2.7
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ MandrakeSoft Corporate Server 2.1 x86_64
+ MandrakeSoft Corporate Server 2.1
+ Mandriva Linux Mandrake 10.2 x86_64
+ Mandriva Linux Mandrake 10.2
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Desktop 4.0
RedHat Desktop 3.0
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Conectiva Linux 10.0

- 漏洞讨论

slocate is susceptible to a local database corruption vulnerability. This issue is due to a failure of the application to handle unexpected directory and filename input.

This issue presents itself when the affected utility attempts to index specially crafted directory structures. The utility fails to handle the directory structure, and fails to complete the indexing process.

This vulnerability allows local attackers to cause the premature failure of the index process, resulting in an incomplete database. If the database is used in further security, backup, or other critical functions, incomplete data may result in the failure of services dependent on it.

This issue is reported in version 2.7 of slocate, but other versions may also be affected.

- 漏洞利用

An exploit is not required.

- 解决方案

Mandriva has released advisory MDKSA-2005:147, along with fixes to address this issue. Please see the referenced advisory for further information.

TurboLinux has released security advisory TLSA-2005-91 addressing this issue. Please see the referenced advisory for details on obtaining and applying the appropriate updates.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

RedHat has released security advisory RHSA-2005:345-24 addressing this issue. Please see the referenced advisory for details on obtaining and applying the appropriate updates.

RedHat has released security advisory RHSA-2005:346-19 addressing this issue for their Desktop and Enterprise editions. Please see the referenced advisory for
further information.

Conectiva Linux has released security advisory CLSA-2005:1028 addressing this issue. Please see the referenced advisory for details on obtaining and applying the appropriate updates.


Conectiva Linux 10.0

slocate slocate 2.7

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站