CVE-2005-2469
CVSS4.6
发布时间 :2005-10-20 06:02:00
修订时间 :2008-09-05 16:51:50
NMCO    

[原文]Stack-based buffer overflow in the NMAP Agent for Novell NetMail 3.52C and possibly earlier versions allows local users to execute arbitrary code via a long user name in the USER command.


[CNNVD]Novell NetMail NMAP代理远程溢出漏洞(CNNVD-200510-150)

        Novell NetMail是基于Internet标准消息和安全协议的邮件和日历系统。
        NetMail Network网络消息应用协议(NMAP)代理中存在远程栈溢出漏洞。NMAP代理在处理USER命令中超长的用户名时存在边界条件错误,允许攻击者执行任意代码。攻击者必须有效的登录到NMAP代理才能利用这个漏洞。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2469
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2469
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200510-150
(官方数据源) CNNVD

- 其它链接及资源

http://support.novell.com/cgi-bin/search/searchtid.cgi?/2972438.htm
(PATCH)  CONFIRM  http://support.novell.com/cgi-bin/search/searchtid.cgi?/2972438.htm
http://support.novell.com/cgi-bin/search/searchtid.cgi?/2972433.htm
(PATCH)  CONFIRM  http://support.novell.com/cgi-bin/search/searchtid.cgi?/2972433.htm
http://support.novell.com/cgi-bin/search/searchtid.cgi?/2972340.htm
(PATCH)  CONFIRM  http://support.novell.com/cgi-bin/search/searchtid.cgi?/2972340.htm
http://secunia.com/secunia_research/2005-23/advisory/
(VENDOR_ADVISORY)  MISC  http://secunia.com/secunia_research/2005-23/advisory/
http://secunia.com/advisories/15925/
(VENDOR_ADVISORY)  SECUNIA  15925
http://xforce.iss.net/xforce/xfdb/22727
(UNKNOWN)  XF  netmail-nmap-user-bo(22727)
http://www.securityfocus.com/bid/15080
(UNKNOWN)  BID  15080
http://www.osvdb.org/19916
(UNKNOWN)  OSVDB  19916
http://securitytracker.com/id?1015048
(UNKNOWN)  SECTRACK  1015048
http://archives.neohapsis.com/archives/fulldisclosure/2005-10/0299.html
(UNKNOWN)  FULLDISC  20051012 Secunia Research: Novell NetMail NMAP Agent "USER" Buffer Overflow Vulnerability

- 漏洞信息

Novell NetMail NMAP代理远程溢出漏洞
中危 缓冲区溢出
2005-10-20 00:00:00 2005-10-20 00:00:00
远程  
        Novell NetMail是基于Internet标准消息和安全协议的邮件和日历系统。
        NetMail Network网络消息应用协议(NMAP)代理中存在远程栈溢出漏洞。NMAP代理在处理USER命令中超长的用户名时存在边界条件错误,允许攻击者执行任意代码。攻击者必须有效的登录到NMAP代理才能利用这个漏洞。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://support.novell.com/cgi-bin/search/searchtid.cgi?/2972340.htm
        http://support.novell.com/cgi-bin/search/searchtid.cgi?/2972433.htm
        http://support.novell.com/cgi-bin/search/searchtid.cgi?/2972438.htm

- 漏洞信息

19916
Novell NetMail NMAP Agent USER Command Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

A remote overflow exists in Novell NetMail. The NMAP (Network Messaging Application Protocol) Agent fails to perform proper bounds checking resulting in a stack-based buffer overflow. With a specially crafted request containing an overly long username in the 'USER' command, a remote attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-10-12 2005-07-18
Unknow Unknow

- 解决方案

Upgrade to version 3.52D or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站