CVE-2005-2396
CVSS4.3
发布时间 :2005-07-27 00:00:00
修订时间 :2008-09-05 16:51:39
NMC    

[原文]Cross-site scripting (XSS) vulnerability in MediaWiki 1.4.6 and earlier allows remote attackers to inject arbitrary web script or HTML via a parameter to the page move template.


[CNNVD]MediaWiki page move template 跨站脚本漏洞(CNNVD-200507-287)

        MediaWiki是用php编写的一套免费的wiki套件。
        MediaWiki 1.4.6及更早版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过页面移动模板的参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mediawiki:mediawiki:1.4_beta6
cpe:/a:mediawiki:mediawiki:1.2.2MediaWiki 1.2.2
cpe:/a:mediawiki:mediawiki:1.4.2MediaWiki 1.4.2
cpe:/a:mediawiki:mediawiki:1.3.11MediaWiki 1.3.11
cpe:/a:mediawiki:mediawiki:1.4_beta4
cpe:/a:mediawiki:mediawiki:1.3.10MediaWiki 1.3.10
cpe:/a:mediawiki:mediawiki:1.4_beta3
cpe:/a:mediawiki:mediawiki:1.4.3MediaWiki 1.4.3
cpe:/a:mediawiki:mediawiki:1.2.4MediaWiki 1.2.4
cpe:/a:mediawiki:mediawiki:1.1.0MediaWiki 1.1.0
cpe:/a:mediawiki:mediawiki:1.3.3MediaWiki 1.3.3
cpe:/a:mediawiki:mediawiki:1.4_beta5
cpe:/a:mediawiki:mediawiki:1.3.2MediaWiki 1.3.2
cpe:/a:mediawiki:mediawiki:1.2.5MediaWiki 1.2.5
cpe:/a:mediawiki:mediawiki:1.3.7MediaWiki 1.3.7
cpe:/a:mediawiki:mediawiki:1.3.0MediaWiki 1.3.0
cpe:/a:mediawiki:mediawiki:1.4.1MediaWiki 1.4.1
cpe:/a:mediawiki:mediawiki:1.3.8MediaWiki 1.3.8
cpe:/a:mediawiki:mediawiki:1.3.6MediaWiki 1.3.6
cpe:/a:mediawiki:mediawiki:1.2.6MediaWiki 1.2.6
cpe:/a:mediawiki:mediawiki:1.2.3MediaWiki 1.2.3
cpe:/a:mediawiki:mediawiki:1.3.1MediaWiki 1.3.1
cpe:/a:mediawiki:mediawiki:1.3.5MediaWiki 1.3.5
cpe:/a:mediawiki:mediawiki:1.4_beta2
cpe:/a:mediawiki:mediawiki:1.3.9MediaWiki 1.3.9
cpe:/a:mediawiki:mediawiki:1.2.1MediaWiki 1.2.1
cpe:/a:mediawiki:mediawiki:1.4_beta1
cpe:/a:mediawiki:mediawiki:1.3MediaWiki 1.3
cpe:/a:mediawiki:mediawiki:1.3.4MediaWiki 1.3.4
cpe:/a:mediawiki:mediawiki:1.4.5MediaWiki 1.4.5
cpe:/a:mediawiki:mediawiki:1.2.0MediaWiki 1.2.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2396
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2396
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-287
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14327
(PATCH)  BID  14327
http://security.gentoo.org/glsa/glsa-200507-18.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200507-18
http://xforce.iss.net/xforce/xfdb/21491
(UNKNOWN)  XF  mediawiki-page-move-xss(21491)
http://www.osvdb.org/17763
(UNKNOWN)  OSVDB  17763
http://secunia.com/advisories/16130
(UNKNOWN)  SECUNIA  16130
http://secunia.com/advisories/15950
(UNKNOWN)  SECUNIA  15950

- 漏洞信息

MediaWiki page move template 跨站脚本漏洞
中危 跨站脚本
2005-07-27 00:00:00 2005-10-20 00:00:00
远程  
        MediaWiki是用php编写的一套免费的wiki套件。
        MediaWiki 1.4.6及更早版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过页面移动模板的参数注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.mediawiki.org/wiki/MediaWiki
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站