CVE-2005-2392
CVSS4.3
发布时间 :2005-07-27 00:00:00
修订时间 :2013-08-03 01:09:30
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in index.php for CMSimple 2.4 and earlier allows remote attackers to inject arbitrary web script or HTML via the search parameter in the search function.


[CNNVD]CMSimple index.php 跨站脚本漏洞(CNNVD-200507-280)

        CMSimple 是一种自由的内容管理系统。架构简单,程式档案小并且反应快速。系统以PHP编写,可以在各种平台上运作。
        CMSimple 2.4及更早版本的index.php中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过search函数中的search参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:cmsmadesimple:cms_made_simple:2.0:beta1CMSimple CMSimple 2.0 Beta 1
cpe:/a:cmsmadesimple:cms_made_simple:2.2:beta3CMSimple CMSimple 2.2 Beta 3
cpe:/a:cmsmadesimple:cms_made_simple:2.3:beta2CMSimple CMSimple 2.3 Beta 2
cpe:/a:cmsmadesimple:cms_made_simple:2.3:beta3CMSimple CMSimple 2.3 Beta 3
cpe:/a:cmsmadesimple:cms_made_simple:2.0:beta3CMSimple CMSimple 2.0 Beta 3
cpe:/a:cmsmadesimple:cms_made_simple:2.2:beta2CMSimple CMSimple 2.2 Beta 2
cpe:/a:cmsmadesimple:cms_made_simple:2.0:beta2CMSimple CMSimple 2.0 Beta 2
cpe:/a:cmsmadesimple:cms_made_simple:1.3:beta1CMS Made Simple 1.3 Beta 1
cpe:/a:cmsmadesimple:cms_made_simple:beta_1
cpe:/a:cmsmadesimple:cms_made_simple:2.4:beta5CMSimple CMSimple 2.4 Beta 5
cpe:/a:cmsmadesimple:cms_made_simple:2.4:beta4CMSimple CMSimple 2.4 Beta 4
cpe:/a:cmsmadesimple:cms_made_simple:2.4:beta1CMSimple CMSimple 2.4 Beta 1
cpe:/a:cmsmadesimple:cms_made_simple:2.4:beta3CMSimple CMSimple 2.4 Beta 3
cpe:/a:cmsmadesimple:cms_made_simple:beta_2
cpe:/a:cmsmadesimple:cms_made_simple:2.4_beta
cpe:/a:cmsmadesimple:cms_made_simple:1.3:beta2CMS Made Simple 1.3 Beta 2
cpe:/a:cmsmadesimple:cms_made_simple:2.3:beta5CMSimple CMSimple 2.3 Beta 5
cpe:/a:cmsmadesimple:cms_made_simple:2.3:beta4CMSimple CMSimple 2.3 Beta 4
cpe:/a:cmsmadesimple:cms_made_simple:2.2:beta4CMSimple CMSimple 2.2 Beta 4
cpe:/a:cmsmadesimple:cms_made_simple:2.0:beta4CMSimple CMSimple 2.0 Beta 4
cpe:/a:cmsmadesimple:cms_made_simple:2.3:beta1CMSimple CMSimple 2.3 Beta 1
cpe:/a:cmsmadesimple:cms_made_simple:2.2:beta1CMSimple CMSimple 2.2 Beta 1
cpe:/a:cmsmadesimple:cms_made_simple:2.2CMSimple CMSimple 2.2
cpe:/a:cmsmadesimple:cms_made_simple:2.1CMSimple CMSimple 2.1
cpe:/a:cmsmadesimple:cms_made_simple:2.3CMSimple CMSimple 2.3
cpe:/a:cmsmadesimple:cms_made_simple:2.4:beta2CMSimple CMSimple 2.4 Beta 2
cpe:/a:cmsmadesimple:cms_made_simple:1.2CMS Made Simple 1.2
cpe:/a:cmsmadesimple:cms_made_simple:1.1CMS Made Simple 1.1
cpe:/a:cmsmadesimple:cms_made_simple:1.0CMS Made Simple 1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2392
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2392
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-280
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14346
(PATCH)  BID  14346
http://www.cmsimple.dk/forum/viewtopic.php?t=2470
(PATCH)  CONFIRM  http://www.cmsimple.dk/forum/viewtopic.php?t=2470
http://securitytracker.com/id?1014556
(PATCH)  SECTRACK  1014556
http://www.securityfocus.com/archive/1/archive/1/442106/100/100/threaded
(UNKNOWN)  BUGTRAQ  20060803 CMSimple Cross Site Scripting
http://www.osvdb.org/18128
(UNKNOWN)  OSVDB  18128
http://www.aria-security.net/advisory/cmsimple.txt
(UNKNOWN)  MISC  http://www.aria-security.net/advisory/cmsimple.txt
http://secunia.com/advisories/16147
(VENDOR_ADVISORY)  SECUNIA  16147
http://lostmon.blogspot.com/2005/07/cmsimple-search-variable-xss.html
(UNKNOWN)  MISC  http://lostmon.blogspot.com/2005/07/cmsimple-search-variable-xss.html

- 漏洞信息

CMSimple index.php 跨站脚本漏洞
中危 跨站脚本
2005-07-27 00:00:00 2006-08-30 00:00:00
远程  
        CMSimple 是一种自由的内容管理系统。架构简单,程式档案小并且反应快速。系统以PHP编写,可以在各种平台上运作。
        CMSimple 2.4及更早版本的index.php中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过search函数中的search参数注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.cmsimple.dk/forum/viewtopic.php?t=2470

- 漏洞信息

18128
CMSimple search Function XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

CMSimple contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the search function. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-07-21 2005-07-13
2005-07-21 2005-07-21

- 解决方案

Upgrade to version 2.5 beta 3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站