CVE-2005-2383
CVSS7.5
发布时间 :2005-07-26 00:00:00
修订时间 :2016-10-17 23:26:38
NMCO    

[原文]SQL injection vulnerability in auth.php in PHPNews 1.2.5 allows remote attackers to execute arbitrary SQL commands via the user parameter in an HTTP POST request.


[CNNVD]PHPNews Auth.PHP SQL注入漏洞(CNNVD-200507-260)

        PHPNews是一款非常强大的新闻发布软件。
        PHPNews 1.2.5的auth.php存在SQL注入漏洞。远程攻击者可以通过HTTP POST请求中的user参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2383
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2383
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-260
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112189453304389&w=2
(UNKNOWN)  BUGTRAQ  20050720 PHPNews SQL injection vulnerability
http://newsphp.sourceforge.net/changelog/changelog_1.30.txt
(PATCH)  CONFIRM  http://newsphp.sourceforge.net/changelog/changelog_1.30.txt
http://www.securityfocus.com/bid/14333
(UNKNOWN)  BID  14333

- 漏洞信息

PHPNews Auth.PHP SQL注入漏洞
高危 SQL注入
2005-07-26 00:00:00 2005-10-20 00:00:00
远程  
        PHPNews是一款非常强大的新闻发布软件。
        PHPNews 1.2.5的auth.php存在SQL注入漏洞。远程攻击者可以通过HTTP POST请求中的user参数执行任意SQL命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://sourceforge.net/projects/newsphp/files/

- 漏洞信息

18129
PHPNews auth.php Multiple Field SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

PHPNews contains a flaw that may allow a remote attacker to carry out an SQL injection attack. The issue is due to the 'auth.php' script not properly sanitizing user-supplied input to the 'Username' and 'Password' field. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-07-20 Unknow
2005-07-20 Unknow

- 解决方案

Upgrade to version 1.3.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站