发布时间 :2005-09-06 17:03:00
修订时间 :2008-11-11 00:51:41

[原文]Cross-site scripting (XSS) vulnerability in Hiki 0.8.0 to 0.8.2 allows remote attackers to inject arbitrary web script or HTML via "missing pages" in which the page name is not properly escaped, a different vulnerability than CVE-2005-2803.

[CNNVD]Hiki 跨站脚本漏洞(CNNVD-200509-037)

        Hiki 0.8.0至0.8.2版本存在跨站脚本漏洞。这使得远程攻击者可以借助于其名称没有正确地转义的"丢失页面"注入任意的web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  JVN  JVN#38138980
(UNKNOWN)  BID  15021

- 漏洞信息

Hiki 跨站脚本漏洞
中危 跨站脚本
2005-09-06 00:00:00 2005-10-25 00:00:00
        Hiki 0.8.0至0.8.2版本存在跨站脚本漏洞。这使得远程攻击者可以借助于其名称没有正确地转义的"丢失页面"注入任意的web脚本或HTML。

- 公告与补丁

        Hiki Hiki 0.8
        Hiki hiki-0.8.4.tar.gz
        Hiki Hiki 0.8.1
        Hiki hiki-0.8.4.tar.gz
        Hiki Hiki 0.8.2
        Hiki hiki-0.8.4.tar.gz

- 漏洞信息

Hiki missing pages Page Name XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Hiki contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate a page name when a user accesses missing pages. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-08-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.8.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Hiki Multiple Cross-Site Scripting Vulnerabilities
Input Validation Error 15021
Yes No
2005-09-06 12:00:00 2006-09-05 11:43:00
These vulnerabilities were announced by the vendor.

- 受影响的程序版本

Hiki Hiki 0.8.2
Hiki Hiki 0.8.1
Hiki Hiki 0.8
Hiki Hiki 0.8.3
Hiki Hiki 0.6.6

- 不受影响的程序版本

Hiki Hiki 0.8.3
Hiki Hiki 0.6.6

- 漏洞讨论

Hiki is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input.

An attacker may leverage these issues to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site.This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has addressed this issue in version 0.8.3:

Hiki Hiki 0.8

Hiki Hiki 0.8.1

Hiki Hiki 0.8.2

- 相关参考