CVE-2005-2332
CVSS4.3
发布时间 :2005-07-20 00:00:00
修订时间 :2008-09-05 16:51:30
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in PHPPageProtect 1.0.0a allows remote attackers to inject arbitrary web script or HTML via the username parameter to (1) admin.php or (2) login.php.


[CNNVD]PHPPageProtect admin.php/login.php 跨站脚本漏洞(CNNVD-200507-238)

        PHPPageProtect是一套用户验证系统,使用密码对指定的网页提供保护。
        PHPPageProtect 1.0.0a存在跨站脚本漏洞。
        远程攻击者可以通过admin.php或login.php的用户名参数注入任意Web脚本或HTML页面。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2332
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2332
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-238
(官方数据源) CNNVD

- 其它链接及资源

http://securitytracker.com/id?1014510
(UNKNOWN)  SECTRACK  1014510
http://secunia.com/advisories/16110
(VENDOR_ADVISORY)  SECUNIA  16110
http://www.securityfocus.com/bid/14318
(UNKNOWN)  BID  14318
http://www.securityfocus.com/bid/14314
(UNKNOWN)  BID  14314

- 漏洞信息

PHPPageProtect admin.php/login.php 跨站脚本漏洞
中危 跨站脚本
2005-07-20 00:00:00 2005-10-20 00:00:00
远程  
        PHPPageProtect是一套用户验证系统,使用密码对指定的网页提供保护。
        PHPPageProtect 1.0.0a存在跨站脚本漏洞。
        远程攻击者可以通过admin.php或login.php的用户名参数注入任意Web脚本或HTML页面。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://php.warpedweb.net/

- 漏洞信息

18065
PHPPageProtect admin.php username Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PHPPageProtect contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'username' variable upon submission to the admin.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-07-18 Unknow
2005-07-18 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站