CVE-2005-2330
CVSS5.0
发布时间 :2005-07-20 00:00:00
修订时间 :2008-09-05 16:51:29
NMCO    

[原文]Directory traversal vulnerability in extras/update.php in osCommerce 2.2 allows remote attackers to read arbitrary files via (1) .. sequences or (2) a full pathname in the readme_file parameter.


[CNNVD]osCommerce extras/update.php 信息泄露漏洞(CNNVD-200507-244)

        osCommerce是一套电子商务与线上商店管理的软件。基于php和mysql,它能够被使用在任何的web server上。它是采用GNU General Public License授权的自由软件。
        osCommerce 2.2的extras/update.php存在目录遍历漏洞。远程攻击者可以通过readme_file参数中的(1)".."(参数值包含'..')序列或(2)完整路径名读取任意文件从而造成信息泄露。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2330
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2330
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-244
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/25861
(UNKNOWN)  XF  oscommerce-extrasupdate-info-disclosure(25861)
http://www.securityfocus.com/bid/14294
(UNKNOWN)  BID  14294
http://www.securityfocus.com/archive/1/431068
(UNKNOWN)  BUGTRAQ  20060414 RE: osCommerce "extras/" information/source code disclosure
http://www.securityfocus.com/archive/1/431012
(UNKNOWN)  BUGTRAQ  20060414 osCommerce "extras/" information/source code disclosure
http://www.osvdb.org/18249
(UNKNOWN)  OSVDB  18249
http://www.oscommerce.com/community/bugs,2835
(UNKNOWN)  MISC  http://www.oscommerce.com/community/bugs,2835
http://sourceforge.net/mailarchive/message.php?msg_id=12318248
(UNKNOWN)  MISC  http://sourceforge.net/mailarchive/message.php?msg_id=12318248
http://securitytracker.com/id?1015944
(UNKNOWN)  SECTRACK  1015944
http://retrogod.altervista.org/oscommerce_22_adv.html
(UNKNOWN)  MISC  http://retrogod.altervista.org/oscommerce_22_adv.html

- 漏洞信息

osCommerce extras/update.php 信息泄露漏洞
中危 路径遍历
2005-07-20 00:00:00 2006-06-14 00:00:00
远程  
        osCommerce是一套电子商务与线上商店管理的软件。基于php和mysql,它能够被使用在任何的web server上。它是采用GNU General Public License授权的自由软件。
        osCommerce 2.2的extras/update.php存在目录遍历漏洞。远程攻击者可以通过readme_file参数中的(1)".."(参数值包含'..')序列或(2)完整路径名读取任意文件从而造成信息泄露。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.oscommerce.com/

- 漏洞信息

18249
osCommerce update.php readme_file Parameter Arbitrary File Access
Remote / Network Access
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-07-18 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站