发布时间 :2005-07-26 00:00:00
修订时间 :2016-10-17 23:25:55

[原文]Cross-site scripting (XSS) vulnerability in Novell Groupwise WebAccess 6.5 before July 11, 2005 allows remote attackers to inject arbitrary web script or HTML via an e-mail message with an encoded javascript URI (e.g. "j&#X41vascript" in an IMG tag.

[CNNVD]Novell GroupWise WebAccess 跨站脚本漏洞(CNNVD-200507-246)

        Novell GroupWise是Novell出品的一种目录服务系统。
        2005年7月11日之前的Novell Groupwise WebAccess 6.5版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过具有已编码javascript URI(例如IMG标记中的"jAvascript")的电子邮件消息注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:novell:groupwise_webaccess:6.5Novell GroupWise WebAccess 6.5

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050719 [ISR] - Novell Groupwise WebAccess Cross-Site Scripting
(UNKNOWN)  BID  14310
(PATCH)  XF  novell-groupwise-webaccess-xss(21421)

- 漏洞信息

Novell GroupWise WebAccess 跨站脚本漏洞
中危 跨站脚本
2005-07-26 00:00:00 2006-04-07 00:00:00
        Novell GroupWise是Novell出品的一种目录服务系统。
        2005年7月11日之前的Novell Groupwise WebAccess 6.5版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过具有已编码javascript URI(例如IMG标记中的"jAvascript")的电子邮件消息注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

Novell GroupWise WebAccess E-Mail IMG SRC XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Novell GroupWise WebAccess contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate e-mail message upon submission to the dynamically generated web content. This could allow a user to send a specially crafted e-mail that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-07-15 2005-06-14
2005-07-19 Unknow

- 解决方案

Upgrade to version 6.5 (dated after 11/7/2005) or 6.5 SP5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Novell GroupWise WebAccess HTML Injection Vulnerability
Input Validation Error 14310
Yes No
2005-07-15 12:00:00 2009-07-12 04:06:00
Discovery is credited to Francisco Amato of Infobyte Security Research.

- 受影响的程序版本

Novell Groupwise 6.5 SP4
Novell Groupwise 6.5 SP3
Novell Groupwise 6.5 SP2
Novell Groupwise 6.5 SP1
Novell Groupwise 6.5

- 漏洞讨论

Novell GroupWise WebAccess is prone to an HTML injection vulnerability. This may be used to inject hostile HTML and script code into the Web mail application. When a user opens an email containing the hostile code, it may be rendered in their browser.

Successful exploitation could potentially allow theft of cookie-based authentication. Other attacks are also possible.

- 漏洞利用

An example email message body was provided:

<IMG SRC="j&#X41vascript:alert(document.cookie)">

- 解决方案

The vendor has announced that GroupWise releases dated after July 11, 2005 are not affected. Please contact the vendor for information on obtaining an upgraded version. This fix will also be included in Novell GroupWise 6.5 SP5 when it is released.

- 相关参考