发布时间 :2005-07-12 00:00:00
修订时间 :2016-10-17 23:25:48

[原文]** DISPUTED ** Dragonfly Commerce allows remote attackers to change a product price by modifying the x_DragonflyCartProductPrice hidden field to (1) dc_Categorieslist.asp, (2) dc_Categoriesview.asp, (3) dc_productslist.asp, and (4) dc_productslist_Clearance.asp. NOTE: the vendor has disputed this issue, saying that "Dragonfly Commerce does not allow for editing prices nor does it allow for viewing information about clients stored in the database except by the store owner and authorized staff as appointed in the store administration." However, SecurityTracker claims that they have been able to confirm the problem.

[CNNVD]incredibleinteractive DragonflyCommerce 多个 数据篡改漏洞(CNNVD-200507-139)

        Dragonfly Commerce是一套电子商务网站解决方案。
        Dragonfly Commerce存在数据篡改漏洞。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050712 Dragonfly Shopping Cart Multiple vulnerabilities

- 漏洞信息

incredibleinteractive DragonflyCommerce 多个 数据篡改漏洞
中危 未知
2005-07-12 00:00:00 2006-06-15 00:00:00
        Dragonfly Commerce是一套电子商务网站解决方案。
        Dragonfly Commerce存在数据篡改漏洞。

- 公告与补丁


- 漏洞信息

Dragonfly Commerce dc_Categoriesview.asp Hidden Field Modification Product Price Manipulation
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Dragonfly Commerce contains a flaw that may allow a remote attacker to manipulate prices without authorization. The issue is due to the dc_Categoriesview.asp script not properly sanitizing user input. By modifying the 'x_DragonflyCartProductPrice' hidden field before submission, it is possible for an attacker to manipulate prices in the system before purchasing an item.

- 时间线

2005-07-12 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Incredible Interactive has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者