CVE-2005-2215
CVSS4.3
发布时间 :2005-07-12 00:00:00
修订时间 :2008-09-05 16:51:11
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.x before 1.4.6 and 1.5 before 1.5beta3 allows remote attackers to inject arbitrary web script or HTML via a parameter in the page move template, a different vulnerability than CVE-2005-1888.


[CNNVD]MediaWiki PageMoveTemplate 跨站脚本攻击漏洞(CNNVD-200507-122)

        MediaWiki是一套以PHP编写的Wiki软件包。
        MediaWiki(低于1.4.6的1.4.x版本及低于1.5beta3的1.5版本)中存在跨站脚本攻击漏洞。
        远程攻击者可通过页面移动模板中的参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mediawiki:mediawiki:1.5_beta2
cpe:/a:mediawiki:mediawiki:1.4_beta6
cpe:/a:mediawiki:mediawiki:1.4.3MediaWiki 1.4.3
cpe:/a:mediawiki:mediawiki:1.5_alpha1
cpe:/a:mediawiki:mediawiki:1.4.1MediaWiki 1.4.1
cpe:/a:mediawiki:mediawiki:1.4.2MediaWiki 1.4.2
cpe:/a:mediawiki:mediawiki:1.4.5MediaWiki 1.4.5
cpe:/a:mediawiki:mediawiki:1.5_beta1
cpe:/a:mediawiki:mediawiki:1.5_alpha2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2215
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2215
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-122
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14181
(PATCH)  BID  14181
http://sourceforge.net/project/shownotes.php?release_id=340290
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=340290
http://secunia.com/advisories/15950
(VENDOR_ADVISORY)  SECUNIA  15950
http://www.novell.com/linux/security/advisories/2005_19_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2005:019

- 漏洞信息

MediaWiki PageMoveTemplate 跨站脚本攻击漏洞
中危 跨站脚本
2005-07-12 00:00:00 2005-10-25 00:00:00
远程  
        MediaWiki是一套以PHP编写的Wiki软件包。
        MediaWiki(低于1.4.6的1.4.x版本及低于1.5beta3的1.5版本)中存在跨站脚本攻击漏洞。
        远程攻击者可通过页面移动模板中的参数注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.mediawiki.org/wiki/Download

- 漏洞信息

17763
MediaWiki Page Move Template XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

MediaWiki contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate an unspecified parameter upon submission to the page move template. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-07-07 Unknow
2005-07-07 Unknow

- 解决方案

Upgrade to version 1.4.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MediaWiki Page Move Cross-Site Scripting Vulnerability
Input Validation Error 14181
Yes No
2005-07-07 12:00:00 2009-07-12 04:06:00
The vendor is credited with the discovery of this vulnerability.

- 受影响的程序版本

S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
MediaWiki MediaWiki 1.5 beta2
MediaWiki MediaWiki 1.5 beta1
MediaWiki MediaWiki 1.5 alpha2
MediaWiki MediaWiki 1.5 alpha1
MediaWiki MediaWiki 1.4.5
MediaWiki MediaWiki 1.4.3
MediaWiki MediaWiki 1.4.2
MediaWiki MediaWiki 1.4.1
MediaWiki MediaWiki 1.4 beta6
MediaWiki MediaWiki 1.5 beta3
MediaWiki MediaWiki 1.4.6

- 不受影响的程序版本

MediaWiki MediaWiki 1.5 beta3
MediaWiki MediaWiki 1.4.6

- 漏洞讨论

MediaWiki is prone to cross-site scripting attacks. This issue is due to a failure of proper sanitization of input variables by the application.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has released an upgrade. All versions up to and including 1.4.5 should be upgraded.

SUSE has released a security summary report (SUSE-SR:2005:019) addressing this and other issues. Please see the referenced advisory for further information.


MediaWiki MediaWiki 1.4 beta6

MediaWiki MediaWiki 1.4.1

MediaWiki MediaWiki 1.4.2

MediaWiki MediaWiki 1.4.3

MediaWiki MediaWiki 1.4.5

MediaWiki MediaWiki 1.5 beta1

MediaWiki MediaWiki 1.5 alpha1

MediaWiki MediaWiki 1.5 beta2

MediaWiki MediaWiki 1.5 alpha2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站