CVE-2005-2213
CVSS7.5
发布时间 :2005-07-11 00:00:00
修订时间 :2008-09-10 15:41:36
NMCO    

[原文]Buffer overflow in the mms_interp_header function in mms.c in MMS Ripper before 0.6.4 might allow remote attackers to execute arbitrary code via a file with more than 20 streams.


[CNNVD]MMSRipper mms.c 缓冲区溢出漏洞(CNNVD-200507-113)

        MMS Ripper是MMS协议的客户端软件。
        MMS Ripper 0.6.4之前版本中mms.c的mms_interp_header函数存在缓冲区溢出漏洞。
        远程攻击者可通过具有超过20个流的文件执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mms_ripper:mms_ripper:0.6.2
cpe:/a:mms_ripper:mms_ripper:0.6.0
cpe:/a:mms_ripper:mms_ripper:0.4.1
cpe:/a:mms_ripper:mms_ripper:0.4.0
cpe:/a:mms_ripper:mms_ripper:0.4.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2213
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2213
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-113
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/15987
(VENDOR_ADVISORY)  SECUNIA  15987
http://nbenoit.tuxfamily.org/projects/mmsrip/ChangeLog
(UNKNOWN)  CONFIRM  http://nbenoit.tuxfamily.org/projects/mmsrip/ChangeLog

- 漏洞信息

MMSRipper mms.c 缓冲区溢出漏洞
高危 缓冲区溢出
2005-07-11 00:00:00 2005-10-20 00:00:00
远程  
        MMS Ripper是MMS协议的客户端软件。
        MMS Ripper 0.6.4之前版本中mms.c的mms_interp_header函数存在缓冲区溢出漏洞。
        远程攻击者可通过具有超过20个流的文件执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://nbenoit.tuxfamily.org/projects.php?rq=mmsrip

- 漏洞信息

17795
MMS Ripper Unspecified Crafted File Issue
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

A remote overflow exists in MMS Ripper. The issue is due to a boundary error in the "mms_interp_header()" function when processing stream IDs from Microsoft Media Services MMST streams. With a specially crafted request with more than 20 Stream IDs, an attacker can cause a buffer overflow resulting in a loss of integrity.

- 时间线

2005-07-09 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.6.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站