发布时间 :2005-07-11 00:00:00
修订时间 :2008-09-05 16:51:08

[原文]PHP remote file inclusion vulnerability in inc/ in PPA web photo gallery 0.5.6 allows remote attackers to execute arbitrary code via the config[ppa_root_path] variable.

[CNNVD]PPA WebPhotoGallery 远程文件包含漏洞(CNNVD-200507-118)

        PPA Web Photo Gallery是一套Web图片管理系统。
        PPA Web Photo Gallery 0.5.6中的inc/存在PHP远程文件包含漏洞。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  14209

- 漏洞信息

PPA WebPhotoGallery 远程文件包含漏洞
高危 输入验证
2005-07-11 00:00:00 2006-10-05 00:00:00
        PPA Web Photo Gallery是一套Web图片管理系统。
        PPA Web Photo Gallery 0.5.6中的inc/存在PHP远程文件包含漏洞。

- 公告与补丁


- 漏洞信息

PPA config[ppa_root_path] Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown

- 漏洞描述

PPA contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to not properly sanitizing user input supplied to the 'config[ppa_root_path]' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2005-07-12 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

DUware DUportal Pro Multiple SQL Injection Vulnerabilities
Input Validation Error 14029
Yes No
2005-06-22 12:00:00 2009-07-12 04:06:00
dedi dwianto <> is credited with the discovery of this vulnerability.

- 受影响的程序版本

DUware DUportal Pro 3.4.3

- 漏洞讨论

DUportal Pro is prone to multiple SQL injection vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input before using it in SQL queries.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

Some of these issues may have previously been discussed in BID 13285 and BID 13288.

- 漏洞利用

No exploit is required.

The following proof of concept URI are available:[SQL Inject]&amp;nChannel=Articles[SQL Inject]&amp;iCat=292&amp;iChannel=2&amp;nChannel=Articles[SQL Inject][SQL Inject]&amp;iChannel=16&amp;nChannel=Topics[SQL Inject]&amp;nChannel=Polls[SQL Inject][SQL Inject][SQL inject]&amp;nChannel=[Name Module]

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考