CVE-2005-2183
CVSS7.5
发布时间 :2005-07-11 00:00:00
修订时间 :2016-10-17 23:25:31
NMCO    

[原文]class.xmail.php in PhpXmail 0.7 through 1.1 does not properly handle large passwords, which prevents an error message from being returned and allows remote attackers to bypass authentication and gain unauthorized access.


[CNNVD]PHPXmail class.xmail.php 绕过身份认证漏洞 (CNNVD-200507-112)

        PHPXmail是基于Web的Xmail邮件服务器管理软件,用PHP语言编写。
        PHPXmail 0.7至1.1版本中的class.xmail.php中存在绕过身份认证漏洞。
        由于不能正确处理超长的用户密码,在出错后不会返回错误信息,这使得远程攻击者可利用此漏洞绕过身份认证,进行非授权访问。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpxmail:phpxmail:0.7
cpe:/a:phpxmail:phpxmail:1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2183
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2183
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-112
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112067694016410&w=2
(UNKNOWN)  BUGTRAQ  20050706 PHPXMAIL - Authentication Bypass

- 漏洞信息

PHPXmail class.xmail.php 绕过身份认证漏洞
高危 授权问题
2005-07-11 00:00:00 2005-10-20 00:00:00
远程  
        PHPXmail是基于Web的Xmail邮件服务器管理软件,用PHP语言编写。
        PHPXmail 0.7至1.1版本中的class.xmail.php中存在绕过身份认证漏洞。
        由于不能正确处理超长的用户密码,在出错后不会返回错误信息,这使得远程攻击者可利用此漏洞绕过身份认证,进行非授权访问。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://sourceforge.net/projects/phpxmail/files/

- 漏洞信息

17762
PHPXmail Password Field Overflow Authentication Bypass
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-07-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站