发布时间 :2005-07-06 00:00:00
修订时间 :2016-10-17 23:25:20

[原文]Cross-site scripting (XSS) vulnerability in phpBB 2.0.16 allows remote attackers to inject arbitrary web script or HTML via nested [url] tags.

[CNNVD]phpBB [url]标记 跨站脚本攻击漏洞(CNNVD-200507-070)

        phpBB 2.0.16中存在跨站脚本攻击漏洞。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050705 XSS in nested tag in phpbb 2.0.16

- 漏洞信息

phpBB [url]标记 跨站脚本攻击漏洞
中危 跨站脚本
2005-07-06 00:00:00 2005-10-20 00:00:00
        phpBB 2.0.16中存在跨站脚本攻击漏洞。

- 公告与补丁


- 漏洞信息 (F38931)

Debian Linux Security Advisory 768-1 (PacketStormID:F38931)
2005-07-28 00:00:00

Debian Security Advisory DSA 768-1 - A cross-site scripting vulnerability has been detected in phpBB2 that allows remote attackers to inject arbitrary web script or HTML via nested tags.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 768-1                                        Martin Schulze
July 27th, 2005               
- --------------------------------------------------------------------------

Package        : phpbb2
Vulnerability  : missing input validation
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2005-2161
Debian Bug     : 317739

A cross-site scripting vulnerability has been detected in phpBB2, a
fully featured and skinneable flat webforum software, that allows
remote attackers to inject arbitrary web script or HTML via nested

The old stable distribution (woody) does not contain phpbb2.

For the stable distribution (sarge) this problem has been fixed in
version 2.0.13-6sarge1.

For the unstable distribution (sid) this problem has been fixed in
version 2.0.13-6sarge1.

We recommend that you upgrade your phpbb2 packages.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:
      Size/MD5 checksum:      783 a2192409bb6c743be83d87529e00ebcc
      Size/MD5 checksum:    61579 e5a598478e4f01a3e8981b72c1356445
      Size/MD5 checksum:  3340445 678d0cb0372e46402a472c510fb90d78

  Architecture independent components:
      Size/MD5 checksum:    36996 9d27f1ba0c529544447be2537a2e427c
      Size/MD5 checksum:  2868362 8de633213b53ff0c2029b0b3e28aa847
      Size/MD5 checksum:   525020 2e0d83079efc4321532e062a4c746598

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.4.1 (GNU/Linux)



- 漏洞信息

phpBB Nested url BBCode Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

phpBB contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate nested [URL] tags for arbitrary HTML or web script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-07-05 Unknow
2005-07-05 Unknow

- 解决方案

Upgrade to version 2.0.17 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHPBB Nested BBCode URL Tag Script Injection Vulnerability
Input Validation Error 14151
Yes No
2005-05-20 12:00:00 2009-07-12 04:06:00
"alex" <> is credited with the discovery of this vulnerability.

- 受影响的程序版本

phpBB Group phpBB 2.0.16
phpBB Group phpBB 2.0.13
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
phpBB Group phpBB 2.0.17

- 不受影响的程序版本

phpBB Group phpBB 2.0.17

- 漏洞讨论

phpBB is prone to a script injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required.

The following proof of concept is available:

- 解决方案

The vendor has addressed this issue in phpBB version 2.0.17.

Debian has released security advisory DSA 768-1 addressing this issue. Please see the referenced advisory for details on obtaining and applying the appropriate updates.

phpBB Group phpBB 2.0.13

phpBB Group phpBB 2.0.16

- 相关参考