CVE-2005-2155
CVSS7.5
发布时间 :2005-07-06 00:00:00
修订时间 :2008-09-10 15:41:10
NMCO    

[原文]PHP remote file inclusion vulnerability in EasyPHPCalendar 6.1.5 and earlier allows remote attackers to execute arbitrary code via the serverPath parameter.


[CNNVD]EasyPHPCalendar serverPath 远程文件包含漏洞(CNNVD-200507-058)

        EasyPHPCalendar是一款Web日历工具。
        EasyPHPCalendar 6.1.5及之前版本中存在PHP远程文件包含漏洞。
        远程攻击者可通过serverPath参数,执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2155
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2155
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-058
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/15893
(VENDOR_ADVISORY)  SECUNIA  15893

- 漏洞信息

EasyPHPCalendar serverPath 远程文件包含漏洞
高危 未知
2005-07-06 00:00:00 2005-10-20 00:00:00
远程  
        EasyPHPCalendar是一款Web日历工具。
        EasyPHPCalendar 6.1.5及之前版本中存在PHP远程文件包含漏洞。
        远程攻击者可通过serverPath参数,执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.easyphpcalendar.com/

- 漏洞信息

17723
EasyPHPCalendar calendar.php serverPath Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public, Exploit Unknown

- 漏洞描述

EasyPHPCalendar contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the calendar.php script not properly sanitizing user input supplied to the "serverPath" parameter before it is used to include files. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2005-07-05 Unknow
2005-07-05 Unknow

- 解决方案

Upgrade to version 6.2.8 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: Set the "register_globals" PHP option to "Off".

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站