CVE-2005-2152
CVSS7.5
发布时间 :2005-07-06 00:00:00
修订时间 :2008-09-05 16:51:01
NMCO    

[原文]SQL injection vulnerability in Geeklog before 1.3.11 allows remote attackers to execute arbitrary SQL commands via user comments for an article.


[CNNVD]Geeklog SQL注入漏洞(CNNVD-200507-062)

        Geeklog是一套免费的Web应用系统。
        Geeklog 1.3.11之前版本中存在SQL注入漏洞。
        远程攻击者可通过对文章的用户评论字段,执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:geeklog:geeklog:1.3.8_1_sr2
cpe:/a:geeklog:geeklog:1.3.8_1_sr6
cpe:/a:geeklog:geeklog:1.3.7_sr1
cpe:/a:geeklog:geeklog:1.3.9_sr3
cpe:/a:geeklog:geeklog:1.3.8_1_sr3
cpe:/a:geeklog:geeklog:1.3.9_sr2
cpe:/a:geeklog:geeklog:1.3.8_1
cpe:/a:geeklog:geeklog:1.3.6Geeklog Geeklog 1.3.6
cpe:/a:geeklog:geeklog:1.3.8Geeklog Geeklog 1.3.8
cpe:/a:geeklog:geeklog:1.3.8_1_sr1
cpe:/a:geeklog:geeklog:1.3.7_sr2
cpe:/a:geeklog:geeklog:1.3.7Geeklog Geeklog 1.3.7
cpe:/a:geeklog:geeklog:1.3.7_sr3
cpe:/a:geeklog:geeklog:1.3.8_1_sr5
cpe:/a:geeklog:geeklog:1.3.7_sr4
cpe:/a:geeklog:geeklog:1.3.9_sr1
cpe:/a:geeklog:geeklog:1.3.10Geeklog Geeklog 1.3.10
cpe:/a:geeklog:geeklog:1.3.7_sr5
cpe:/a:geeklog:geeklog:1.3.8_1_sr4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2152
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2152
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-062
(官方数据源) CNNVD

- 其它链接及资源

http://www.hardened-php.net/advisory-062005.php
(VENDOR_ADVISORY)  MISC  http://www.hardened-php.net/advisory-062005.php
http://www.geeklog.net/article.php/geeklog-1.3.11sr1
(VENDOR_ADVISORY)  CONFIRM  http://www.geeklog.net/article.php/geeklog-1.3.11sr1
http://securitytracker.com/id?1014381
(UNKNOWN)  SECTRACK  1014381
http://secunia.com/advisories/15914
(UNKNOWN)  SECUNIA  15914

- 漏洞信息

Geeklog SQL注入漏洞
高危 SQL注入
2005-07-06 00:00:00 2005-10-20 00:00:00
远程  
        Geeklog是一套免费的Web应用系统。
        Geeklog 1.3.11之前版本中存在SQL注入漏洞。
        远程攻击者可通过对文章的用户评论字段,执行任意SQL命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.geeklog.net/

- 漏洞信息

17724
Geeklog Article User Comment SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-07-04 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站