CVE-2005-2146
CVSS4.6
发布时间 :2005-07-05 00:00:00
修订时间 :2008-09-05 16:51:00
NMCO    

[原文]SSH Tectia Server 4.3.1 and earlier, and SSH Secure Shell for Windows Servers, uses insecure permissions when generating the Secure Shell host identification key, which allows local users to access the key and spoof the server.


[CNNVD]ssh.com TectiaServer 信息泄露漏洞(CNNVD-200507-016)

        Tectia Server是一款SSH服务端软件。
        SSH Tectia Server 4.3.1及之前版本和SSH Secure Shell for Windows Servers存在信息泄露漏洞。
        在生成安全Shell代管识别密钥时,由于使用不安全的许可授权,本地用户可访问密钥并欺骗服务器。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2146
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2146
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-016
(官方数据源) CNNVD

- 其它链接及资源

http://www.ssh.com/company/newsroom/article/653/
(VENDOR_ADVISORY)  CONFIRM  http://www.ssh.com/company/newsroom/article/653/
http://secunia.com/advisories/15894
(VENDOR_ADVISORY)  SECUNIA  15894

- 漏洞信息

ssh.com TectiaServer 信息泄露漏洞
中危 未知
2005-07-05 00:00:00 2006-09-05 00:00:00
本地  
        Tectia Server是一款SSH服务端软件。
        SSH Tectia Server 4.3.1及之前版本和SSH Secure Shell for Windows Servers存在信息泄露漏洞。
        在生成安全Shell代管识别密钥时,由于使用不安全的许可授权,本地用户可访问密钥并欺骗服务器。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.ssh.com/

- 漏洞信息

17685
SSH Tectia Server Private Key Permission Weakness
Local Access Required Information Disclosure
Loss of Confidentiality
Exploit Unknown

- 漏洞描述

SSH Tectia Server and SSH Secure Shell for Windows contains a flaw that may allow a malicious user to obtain the server host identification key caused by insufficient file permissions. It is possible that the flaw may allow an attacker to access the host identification key without the required administrative privileges. This key could then be copied and installed on a malicious server to masquerade as the original server.

- 时间线

2005-06-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.3.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站