CVE-2005-2107
CVSS4.3
发布时间 :2005-07-05 00:00:00
修订时间 :2016-10-17 23:25:00
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in post.php in WordPress 1.5.1.2 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) p or (2) comment parameter.


[CNNVD]WordPress post.php 跨站脚本攻击漏洞(CNNVD-200507-007)

        WordPress是一套用于艺术类的Web出版发布系统。
        WordPress 1.5.1.2及之前版本的post.php存在多个跨站脚本攻击漏洞。
        远程攻击者可通过p或comment参数,注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:wordpress:wordpress:1.5WordPress 1.5
cpe:/a:wordpress:wordpress:1.2WordPress 1.2
cpe:/a:wordpress:wordpress:1.0WordPress 1.0
cpe:/a:wordpress:wordpress:1.5.1WordPress 1.5.1
cpe:/a:wordpress:wordpress:1.5.1.2WordPress 1.5.1.2
cpe:/a:wordpress:wordpress:1.0.1WordPress 1.0.1
cpe:/a:wordpress:wordpress:1.0.2WordPress 1.0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2107
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2107
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-007
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112006967221438&w=2
(UNKNOWN)  BUGTRAQ  20050629 WordPress 1.5.1.2 && Earlier Multiple Vulnerabilities
http://www.gulftech.org/?node=research&article_id=00085-06282005
(VENDOR_ADVISORY)  MISC  http://www.gulftech.org/?node=research&article_id=00085-06282005

- 漏洞信息

WordPress post.php 跨站脚本攻击漏洞
中危 跨站脚本
2005-07-05 00:00:00 2005-10-20 00:00:00
远程  
        WordPress是一套用于艺术类的Web出版发布系统。
        WordPress 1.5.1.2及之前版本的post.php存在多个跨站脚本攻击漏洞。
        远程攻击者可通过p或comment参数,注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://wordpress.org/download/

- 漏洞信息

17636
WordPress post.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

WordPress contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'comment' and 'p' variables upon submission to the 'post.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-06-29 Unknow
2005-06-29 Unknow

- 解决方案

Upgrade to version 1.5.1.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站