CVE-2005-2102
CVSS5.0
发布时间 :2005-08-16 00:00:00
修订时间 :2010-08-21 00:30:11
NMCOP    

[原文]The AIM/ICQ module in Gaim before 1.5.0 allows remote attackers to cause a denial of service (application crash) via a filename that contains invalid UTF-8 characters.


[CNNVD]Gaim AIM/ICQ 协议多个安全漏洞(CNNVD-200508-154)

        Gaim是一款Linux系统下的即时通讯软件,是一个同时支持多种协议的即时聊天工具,所支持的协议包括AIM、ICQ、MSN、IRC和Jabber。Gaim处理away消息的方式存在缓冲区溢出漏洞。远程攻击者可以向登陆到AIM或ICQ的Gaim用户发送特制的away消息,导致执行任意代码。Gaim中还存在拒绝服务漏洞。远程攻击者可以向登陆到AIM或ICQ的用户上传有特制文件名的文件,导致Gaim崩溃。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:rob_flynn:gaim:1.1.3
cpe:/a:rob_flynn:gaim:1.1.2
cpe:/a:rob_flynn:gaim:1.2.0
cpe:/a:rob_flynn:gaim:1.1.4
cpe:/a:rob_flynn:gaim:1.0.2
cpe:/a:rob_flynn:gaim:1.2.1
cpe:/a:rob_flynn:gaim:1.3.0
cpe:/a:rob_flynn:gaim:1.1.1
cpe:/a:rob_flynn:gaim:1.1.0
cpe:/a:rob_flynn:gaim:1.0.0
cpe:/a:rob_flynn:gaim:1.0
cpe:/a:rob_flynn:gaim:1.0.3
cpe:/a:rob_flynn:gaim:1.0.1

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9283The AIM/ICQ module in Gaim before 1.5.0 allows remote attackers to cause a denial of service (application crash) via a filename that contain...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2102
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2102
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200508-154
(官方数据源) CNNVD

- 其它链接及资源

http://www.ubuntulinux.org/support/documentation/usn/usn-168-1
(UNKNOWN)  UBUNTU  USN-168-1
http://gaim.sourceforge.net/security/?id=21
(UNKNOWN)  CONFIRM  http://gaim.sourceforge.net/security/?id=21
http://www.securityfocus.com/bid/14531
(UNKNOWN)  BID  14531
http://www.securityfocus.com/archive/1/archive/1/426078/100/0/threaded
(UNKNOWN)  FEDORA  FLSA:158543
http://www.redhat.com/support/errata/RHSA-2005-627.html
(UNKNOWN)  REDHAT  RHSA-2005:627
http://www.novell.com/linux/security/advisories/2005_19_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2005:019

- 漏洞信息

Gaim AIM/ICQ 协议多个安全漏洞
中危 资料不足
2005-08-16 00:00:00 2005-10-20 00:00:00
远程  
        Gaim是一款Linux系统下的即时通讯软件,是一个同时支持多种协议的即时聊天工具,所支持的协议包括AIM、ICQ、MSN、IRC和Jabber。Gaim处理away消息的方式存在缓冲区溢出漏洞。远程攻击者可以向登陆到AIM或ICQ的Gaim用户发送特制的away消息,导致执行任意代码。Gaim中还存在拒绝服务漏洞。远程攻击者可以向登陆到AIM或ICQ的用户上传有特制文件名的文件,导致Gaim崩溃。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        https://www.redhat.com/support/errata/RHSA-2005-627.html
        https://www.redhat.com/support/errata/RHSA-2005-589.html

- 漏洞信息 (F39421)

Gentoo Linux Security Advisory 200508-6 (PacketStormID:F39421)
2005-08-17 00:00:00
Gentoo  security.gentoo.org
advisory,overflow
linux,gentoo
CVE-2005-2102,CVE-2005-2103
[点击下载]

Gentoo Linux Security Advisory GLSA 200508-06 - Brandon Perry discovered that Gaim is vulnerable to a heap-based buffer overflow when handling away messages (CVE-2005-2103). Furthermore, Daniel Atallah discovered a vulnerability in the handling of file transfers (CVE-2005-2102). Versions less than 1.5.0 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200508-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Gaim: Remote execution of arbitrary code
      Date: August 15, 2005
      Bugs: #102000
        ID: 200508-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Gaim is vulnerable to a buffer overflow which could lead to the
execution of arbitrary code or to a Denial of Service.

Background
==========

Gaim is a full featured instant messaging client which handles a
variety of instant messaging protocols.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /  Vulnerable  /                          Unaffected
    -------------------------------------------------------------------
  1  net-im/gaim       < 1.5.0                                >= 1.5.0

Description
===========

Brandon Perry discovered that Gaim is vulnerable to a heap-based buffer
overflow when handling away messages (CAN-2005-2103). Furthermore,
Daniel Atallah discovered a vulnerability in the handling of file
transfers (CAN-2005-2102).

Impact
======

A remote attacker could create a specially crafted away message which,
when viewed by the target user, could lead to the execution of
arbitrary code. Also, an attacker could send a file with a non-UTF8
filename to a user, which would result in a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Gaim users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-im/gaim-1.5.0"

References
==========

  [ 1 ] CAN-2005-2102
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2102
  [ 2 ] CAN-2005-2103
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2103

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200508-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
    

- 漏洞信息

18668
Gaim Non-utf8 Invalid Filename Remote DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Availability
Exploit Public

- 漏洞描述

Gaim contains a flaw that may allow a remote denial of service. The issue is triggered when an attacker attempts to send a file with non-utf8 characters, and will result in loss of availability for the program.

- 时间线

2005-08-10 Unknow
2005-08-10 Unknow

- 解决方案

Upgrade to version 1.5.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站