CVE-2005-2057
CVSS6.8
发布时间 :2005-06-29 00:00:00
修订时间 :2016-10-17 23:24:33
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Infopop UBB.Threads before 6.5.2 Beta allow remote attackers to inject arbitrary web script or HTML via the (1) Searchpage parameter to dosearch.php, (2) Number, (3) what, or (4) page parameter to newreply.php, (5) Number, (6) Board, or (7) what parameter to showprofile.php, (8) fpart or (9) page parameter to showflat.php, or (10) like parameter to showmembers.php.


[CNNVD]Infopop UBB.Threads 多个跨站脚本攻击(XSS)漏洞(CNNVD-200506-229)

        Infopop UBB.Threads 6.5.2 Beta试用版之前的版本中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可借助:(1) 提交到dosearch.php的Searchpage参数,(2) 提交到newreply.php的Number参数,(3) what参数,或(4) page参数, (5) 提交到showprofile.php的Number参数,(6) Board参数,或(7) what参数,(8) 提交到showflat.php的fpart参数,或(9) page参数,或(10) 提交到showmembers.php的like参数,来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:ubbcentral:ubb.threads:6.0.2
cpe:/a:ubbcentral:ubb.threads:6.1.1
cpe:/a:ubbcentral:ubb.threads:6.0.3
cpe:/a:ubbcentral:ubb.threads:6.2.1
cpe:/a:ubbcentral:ubb.threads:6.2.2
cpe:/a:ubbcentral:ubb.threads:6.3.1
cpe:/a:ubbcentral:ubb.threads:6.2.3
cpe:/a:ubbcentral:ubb.threads:6.4.1
cpe:/a:ubbcentral:ubb.threads:6.4.2
cpe:/a:ubbcentral:ubb.threads:6.5.1
cpe:/a:ubbcentral:ubb.threads:6.4.3
cpe:/a:ubbcentral:ubb.threads:6.5.1.1
cpe:/a:ubbcentral:ubb.threads:6.4.4
cpe:/a:ubbcentral:ubb.threads:6.5
cpe:/a:ubbcentral:ubb.threads:6.4
cpe:/a:ubbcentral:ubb.threads:6.1
cpe:/a:ubbcentral:ubb.threads:6.0
cpe:/a:ubbcentral:ubb.threads:6.3
cpe:/a:ubbcentral:ubb.threads:6.2
cpe:/a:ubbcentral:ubb.threads:6.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2057
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2057
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-229
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111963737202040&w=2
(UNKNOWN)  BUGTRAQ  20050624 Infopop UBB Threads Multiple Vulnerabilities
http://www.gulftech.org/?node=research&article_id=00084-06232005
(VENDOR_ADVISORY)  MISC  http://www.gulftech.org/?node=research&article_id=00084-06232005
http://www.ubbcentral.com/boards/showflat.php/Cat/0/Number/42351/Main/42351/#Post42351
(PATCH)  MISC  http://www.ubbcentral.com/boards/showflat.php/Cat/0/Number/42351/Main/42351/#Post42351

- 漏洞信息

Infopop UBB.Threads 多个跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2005-06-29 00:00:00 2005-10-20 00:00:00
远程  
        Infopop UBB.Threads 6.5.2 Beta试用版之前的版本中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可借助:(1) 提交到dosearch.php的Searchpage参数,(2) 提交到newreply.php的Number参数,(3) what参数,或(4) page参数, (5) 提交到showprofile.php的Number参数,(6) Board参数,或(7) what参数,(8) 提交到showflat.php的fpart参数,或(9) page参数,或(10) 提交到showmembers.php的like参数,来注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

17513
UBB.threads newreply.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

UBB.threads contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'Number', 'what', & 'page' variables upon submission to the 'newreply.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-06-23 Unknow
2005-06-23 Unknow

- 解决方案

Upgrade to version 6.5.2 beta or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站