CVE-2005-2052
CVSS5.1
发布时间 :2005-06-28 00:00:00
修订时间 :2016-10-17 23:24:31
NMCO    

[原文]Heap-based buffer overflow in vidplin.dll in RealPlayer 10 and 10.5 (6.0.12.1040 through 1069), RealOne Player v1 and v2, RealPlayer 8 and RealPlayer Enterprise allows remote attackers to execute arbitrary code via an .avi file with a modified strf structure value.


[CNNVD]RealPlayer 'vidplin.dll'文件堆缓冲区溢出漏洞(CNNVD-200506-215)

        RealPlayer 10和10.5 (6.0.12.1040至1069), RealOne Player v1和v2, RealPlayer 8和RealPlayer Enterprise版本中的vidplin.dll文件存在堆缓冲区溢出漏洞,远程攻击者可借助一个带有畸形的strf结构值的.avi文件来执行任意代码。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:realnetworks:realone_player:2.0
cpe:/a:realnetworks:realplayer:::enterprise
cpe:/a:realnetworks:realplayer:10.5_6.0.12.1040
cpe:/a:realnetworks:realplayer:8.0
cpe:/a:realnetworks:realone_player:1.0
cpe:/a:realnetworks:realplayer:10.0RealNetworks RealPlayer 10.0
cpe:/a:realnetworks:realplayer:10.5_6.0.12.1069

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2052
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2052
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-215
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111955853611840&w=2
(UNKNOWN)  BUGTRAQ  20050623 eEye Advisory - EEYEB-200505 - RealPlayer AVI Processing Overflow
http://service.real.com/help/faq/security/050623_player/EN/
(VENDOR_ADVISORY)  CONFIRM  http://service.real.com/help/faq/security/050623_player/EN/

- 漏洞信息

RealPlayer 'vidplin.dll'文件堆缓冲区溢出漏洞
中危 缓冲区溢出
2005-06-28 00:00:00 2006-08-22 00:00:00
远程  
        RealPlayer 10和10.5 (6.0.12.1040至1069), RealOne Player v1和v2, RealPlayer 8和RealPlayer Enterprise版本中的vidplin.dll文件存在堆缓冲区溢出漏洞,远程攻击者可借助一个带有畸形的strf结构值的.avi文件来执行任意代码。

- 公告与补丁

        

- 漏洞信息

17576
RealPlayer/RealOne vidplin.dll Crafted AVI Overflow
Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2005-06-23 Unknow
Unknow 2005-06-23

- 解决方案

Upgrade to version 6.0.12.1212 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站